Hi New from Wilmington NC

SO I started putting it together and reopened my order to double check and I still haven’t gotten the water table and extended piece UH now I got to take it all apart.
Almost ALL my screws and washer and cap packets where labeled wrong. Instead it said use packet 7,8,9 meanwhile all those parts are in packets.
19 ,4, 6. I spent a long time chasing my tail on this.

Well welcome to the forum anyway. And thanks for reporting your woes on the mislabeling, which will serve as a heads-up for those of us yet to start assembly of our own. I got my last package recently too and I’m for sure going to check closer than I otherwise would have.

I’m in Hampstead NC. Welcome

Are you sure you are using the correct instructions? I fear you may be using the old outdated instructions which had a different fastener packaging scheme.

1 Like

That could have been the case. I mean its not hard to figure out what goes with what but it was a pain. Our XL expansion kit shipped today and we just have to install the Z axis kit .

FYI. I am maybe on a similar shipping date (got my last box a week or so ago). Thus far all my hardware was labeled and counted spot on. I’m as far as mounting the Z-axis & gantry bar, so there’s a bit of hardware remaining but a majority of the bags are empty now.

I downloaded & printed what is probably the current assembly instructions and that’s what I’m going by. Everything seems to match so far.

So there’s that.

1 Like

HI Martin from Wilmington.

I have a MASSIVE ask of you.
Is there ANY WAY you could help me set up the crossfire and programming and plasma cutter hook up. I am happy to pay for your time and services. I just don’t have the time to keep running into road blocks to solve each item.

If you cannot , can you recommended someone plz.

thanks Martin.

If you don’t get a taker, try @brownfox - he does one on one sessions with people to help them get up & running & designing.

James is right… @brownfox is available for this…

How much do you have done? Is it assembled? What plasma cutter are you using?

Everything is assembled I ( just got the xl expansion kit yesterday) but I can move in the X and Y direction around the table using the Firecross software. I can move the Z axis up and down. The Plasma cutter they sent me is a Razorweld Razor cut 45.

So what are you needing help with exactly?

First thank you for replying I appreciate it.

  1. I dont know how to remove the razor plasma cutter cover off with handle on to expose eletronics. ( don’t want to use brut force and damage things) Handle is in the way.

  2. My experience on hooking up electronics to the plasma cutter is ZERO

  3. downloaded Mach3 and nothing worked, there was no movement of X or Y or Z. So I uninstalled Mach3 and downloaded * [FireControl 20.6.2] then I could move XYZ direction . I tried to do a dry run with g code from a practice Mach3 file on Firecontrol and I had more errors coming up like protesters during the Nixon administration was not pretty.

I have downloaded fusion 360 and thats where I am at. I dont know if I need sheetcam. I am really frustrated and just need to help to make it that I can plug USB and play. I have a lot of work my plate and just need one thing to go right while I focus on the other machine I have CO2 laser , so my business partner can start working on his projects. Happy to pay for time and expenses.

DM me your phone number and I’ll see if I can help you out.

Hi this community is great