Help with USB connection to CrossFire

I’ve had the CrossFire PRO for the last few months, everything working great, used it extensively to cut out lots of parts.

Now it sat idle for about the last 2 weeks and I am trying to use it and I cannot get Firecontrol and my laptop to communicate. I am running Windows 8 and this laptop is dedicated to the CrossFire (i.e. it also hasnt been used/no new installations, updates etc. the last 2 weeks.) I have the CrossFire Pro w/THC and the latest version of FireControl.

When I plug in the usb to my laptop the green light comes on the control box and I can hear the high pitched humming of the motors/box change but there is no little chime on my PC to indicate a device plugged in (unsure if it usually does it for the crossfire?). I’ve tried all three ports on my laptop, ive also plugged in a mouse on all three to make sure they all work; all good. I’ve also tried using a different usb cord with the same ends on it; no difference. And yes I tried restarting my computer too.

I attempted to reinstall the drivers by following this guide However “Crossfire CNC” does not show up in the list, the “Other devices” tab isn’t even there… I also checked under “Unirversal Serial Bus controllers” at the bottom since I read a few other posts where it showed up under there… I did however uninstall and reinstall FireControl USB THC Driver using the wizard.

I will reiterate that I had everything working great before; I had to manually install the drivers when I first got it a few months ago but otherwise at the time my laptop and Firecontrol worked as it should. And absolutely nothing has changed with my setup since.

I am not super computer savvy and am really hoping there is a super simple solution that I am missing! I’ve been just beating my head against the wall the past few hours with this!

Thanks in advance guys!

I would connect another computer to it to see if it recognizes the USB device. At the very least, you would get a “unknown device” which would confirm the USB is working.

Thanks, that is actually one thing I didn’t think of trying. Plugged the USB into my wives laptop, still nothing, no chime, pop-up etc. I checked in device manager too and doesn’t show up anywhere… Does this mean the issue could be in the control box??

It’s either the control box or the USB cable. I hope you have a extra USB A to B connector lying around so you can test.

He already tried another cable. That’s why I deleted my post, I typed before reading the first post completely.

Yup can confirm I did try another USB cable, thanks guys. I contacted Langmuir support this morning we’ll see what they say… hope this can be easily fixed as I have a time sensitive job… and rather not go back to cutting out freehand lol…

I am having the same problem, do you mind telling me how you fixed it?

Sorry about the very late reply. I assume you already got things sorted out, but for anyone in the future that has this issue this is what happened:

I reached out to Langmuir support, and Aksel. After explaining my problem we exchanged a few emails back and forth, with him helping me troubleshoot. After this he determined that the issue was the motion control board inside of the control box - they shipped me out a new one at no charge (was less than a year old) and walked me through swapping it out. Very painless experience.

That was over 2 years ago and have had no issues since.