Help: Added CPC to Hypertherm 45XP, lost display (SOLVED)

I have a several year old Hypertherm 45XP and personally wired in the compatible CPC port to it. I followed the instructions, and put it back together correctly. I turned the machine on, and tested with the hand torch (not machine torch) (not connected to any CPC device), and it worked correctly firing when it the trigger was pulled.
My problem is the display screen showing the 0-45 does not show anything any more. Turning the dial does not make the display show anything either.
I opened the plasma cutter back up, and disconnected everything I had added with the CPC port, and tried again. The torch would fire, but still without a display on the screen of the plasma cutter.

Anyone have any insight into what could have gone wrong?

@ruffinwood Welcome to The Forum

I would check the J3 connector. Make sure it’s seated, something may have been bumped.

Here’s a link the full service manual

Powermax45 XP Service Manual (809230 revision 2) - Rapid Welding


Fixed! Absolutely brilliant. Thanks for the really fast response, knowledge and resources. It was the J1 cable. It was attached but ever so slightly loose. Clicked it back in and boom everything works perfect. Thanks a lot!