Got FireControl and hardware stuck running break in program

Finished build my Crossfire Pro and attempted to run the break in program and it took me an hour to troubleshoot and recover from that fiasco.

Problem 1: The break in program needs some sort of documentation other than “run it”. I have the limit switches installed and had the table at machine home (upper left corner). First time I ran the program it halted saying the program ran beyond the limits of the table size. I thought maybe the switches needed to be turned off to run the program, and re-ran it.

Suggestion: There needs to be documentation explaining how to setup the machine to run the program correctly.

Problem 2. Without the limit switches enabled, the program crashed both gantries farther into the upper left. Hit Stop. Again, without docs, no idea why this happened.

Problem 3: Somewhere in all this restarting the app and power cycling the hardware, Firecontrol was stuck with no program loaded, Pause button was blinking, and all other controls disabled. Clicking Stop or Pause did nothing. Appeared to think it was running a program, but there was no program. Finally had to track down and delete the preferences file (Mac). That solved this problem.

Suggestion: There is some bug in Firecontrol where it thinks there is a program running, but there isn’t and you can’t tell the app to stop the non-existent program.

Problem 4: With the limit switches now jammed closed, Firecontrol refused to allow me to jog the motors to a better position because there were alarms for the switches being closed. Circular problem. Power cycling and disconnecting the switches did not help. Finally had to power down, rotate the X axis shaft to get off the switch, and then short the connectors for the Y axis to fake the switch being open (two motors, can’t hand rotate to solve).

Suggestion: Firecontrol should not disable jogging for limit switch alarms as you need to be able to jog to clear the switches.

Hoping tomorrow goes better. Filling the tray with water and additive, testing the THC, and trying my first cuts…

I can’t help you with the limit switches, since I don’t have them and don’t want them. They have caused more confusion than any problem they were intended to solve.

The main issue that you experienced with the break in program, is that it was made with the origin at the lower left corner. This means that the torch needs to be zeroed at that location, before starting the program.

If you try to start the program from the “machine home” location at the upper left, the program is completely off the table surface. You can either jog the torch to the lower left corner and hit the “zero all work axes” button to make that the “work home” or use the “set program origin” button to change the origin location to the upper left corner.

Note that you will need to learn to zero your torch at the spot where you want to start your cuts or learn to use work coordinate offsets to place your cuts where you want them in relation to the “machine home” position.


This would not be good for the novice as they may turn right around and run it the wrong direction.
You can jog it off the limits you just have the close out the alarm a couple of times.
First time you hit the jog button it will set the alarm clear and do it again eventually it will jog after a few times.

Hey Dave,

Welcome to the Forum!

  1. I’ll look into clarifying the Getting Started portion of the Assembly Guide to clarify that limit switches should be not yet installed or disabled when running the Break-In program.

  2. The Break-In program definitely should not have crashed the machine, I’ve never heard of this occurring before. The only thing I can think of that would cause this would be that the work zero was incorrectly set off the the machine’s home.

  3. I’ve also never heard of this issue occurring. Which model Mac do you have? Does it happen to have an Apple Silicon (M1/M2) processor? Good idea deleting the .FireControl folder (and good job finding it, I have a shell script that I send to people who need to delete it on Mac). If the issue occurs again, could you get a video and send it to

  4. This can be resolved by disabling hard limits via the Machine Settings window of FireControl, then jogging away from the limit switches. Alternatively, with the machine powered off, you can jog away from the limit switches manually by hand-turning the lead screw.

Thanks for all the valuable input!

1 Like

It was not my experience that clicking the Jog buttons after that cleared anything. Maybe that’s another bug. Regardless, if the switches are detected as closed, it should at least allow jogging in the opposite direction to try and recover.

When I hit the limits it will throw an alarm. I then clear the alarm and jog which ever direction I need to go and it will move a small amount and set the alarm again. I do this 2 or 3 times and away I go.
I know how you feel every time windows come out with a update or new version I send them a email telling them all things I would like them to add to there software and so far I have not seen a one. :rofl:
Trust me once you know what your you will be fine with fire control!

1 Like

I think I was stuck in a special mode for when you trip both switches or when it crashes due to the program. I bumped one of the switches during final setup today and I did get an alert that let me clear the alarm. Weird.

In any event, just wanted to document some of the new user issues I hit in the hopes Langmuir would address them in future releases or documentation and save some future user from hitting the same problems.

I successfully made my first cuts today and they look great! Looking forward playing with this and learning more over the long weekend.


Im running into similar issues. I cant get the HOME button to work at all. ALWAYS crashes my machine past the soft limits that are setup. I ran the break in program as well and it crashed into everything the first time. That process is not clear at all for a first time user. It worked flawlessly after setting zero to the bottom left.

A tip I did figure out for having closed limit switches and no way to jog was just turning off the limit switches in the machine settings. Then you can jog away and turn the switches back on.

1 Like