Gcode Pauses in Mach3

I redownloaded Mach3 to start fresh after a recent glitch.

Since then, every time the torch fires, the gcode pauses till I hit Start on Mach3. This has to be an easy fix, but have not seen a fix in the forums.

To elaborate more it goes something like this:
-Moves to x,y
-torch fires
-pauses in place
-Manually press start
-Moves along cut path till finished (torch turns off correctly)
-Moves to next x,y
-torch fires
-manually press start, and torch moves along cut pattern.
repeat over and over for each time the torch fires.

I can include a video if need be, but figured this would suffice.

Your G-Code would be more useful. There are a number of reasons this could happen.

This could be from the USB cable from your computer to the control box. I had the same issues when I started cutting thicker material and increased the required amperage. Changed the USB cable to one the had the ferrite core on both ends and no longer had the issue.

1 Like

USMC - E9 MGyS3.tap (65.0 KB)

I will try that if problems persist.

G-Code looks fine, but there may be an issue with your Mach 3 Dwell settings. You have a dwell after each torch fire (which makes sense since you want a pierce delay), however, your command sequence is:
G4 P1.

Which could be 1 second delay or 1millisecond delay, depending on how your dwell resolution is set. If you see the Dwell light blinking continuously after the torch fires, maybe Mach 3 isn’t processing the dwell command as you are expecting.

I don’t have Mach 3 running right now so can’t check, but look under General Configuration and the setting is at the top of the fourth column IIRC.

1 Like

Just had the same issue. Found it to be an issue with EMI so we ran a ground wire from the table to the ground in my conduit box. Seems to have fixed the issue for now. Will shout out if it shows its ugly head again.

1 Like

did you get this resolved?? Mine has the same issue right now when I’ve installed mach on a new laptop. My old laptop works fine but the screen slightly cracked so I got a new laptop but it keeps pauses just like yours. I have checked the settings from my old laptop and they are exactly the same.

EDIT: I got this to work. TomWS was right. There is a setting under general configuration that has to be checked. It is G04 ms or something like that. Mine was unchecked on my new laptop but checked on my old laptop. I checked it and now it works perfectly. Thanks so much TomWS!!

1 Like

i just had the same problem with pausing. it started after i moved my plasma cutter under my rolling cart eith my laptop. i movef the plasma cutter back under the cutting table and the problem seems to be fixed