G-Code Debugger within FireControl

I’ve been successfully designing from Sketchup, exporting as a 2D DXF, importing into SheetCam, post processing then opening in FireControl for 4 months now. While I have been happy with the cut quality, I was waiting for my build schedule to slow down to further fine tune my settings.

Today, I used path rules to slow down in small circles/shapes and at corners. That worked successfully in 3 of my production cut files, removing some taper in my cuts. I’ve also been adjusting the pierce delay. Had been 0.5 raised it to 0.7. Not sure that had a big impact on my cut quality just yet. Just noting what I’ve changed.

I used the same path rules and pierce delay on a 4th file. When I load it into FireControl, it either hangs the app up with the spinner (wait cursor) or just makes the UI inoperable.

I ran out of time this morning to undo some of the changes, to see what is causing this. However, it would be useful if there was a debugging mode in FireControl that may help indicate any problems with the file, based on its initial message where it validates the file.

Is there a g-code debugger that would help identify issues?

If you upload the .tap file here, I’ll look at it to see if there are any obvious issues. Generally when this happens, it is because someone inserted a command that Firecontrol doesn’t recognize. The most common one is inserting a code snippet or path rule to turn off the THC. They usually read about it on another forum and insert codes that may work on other machines, but Firecontrol doesn’t recognize them and won’t run the program.

1 Like

That’s actually it. Guess I’m still learning SheetCam. I had created a rule months ago before I read (recently) to NOT turn THC ON and OFF. In my tuning this morning, I had removed those THC calls in the path rules. Worked in the first 3 files. In the 4th one, it has brought those commands back in.

I’ll remove the THC calls from the rule again and re-try.

Thanks for the head’s up to get me to go back and look.

1 Like

Just confirmation on the solution. The Path Rule that I had put together back in April DID include the THC ON/OFF commands. This was something that I had abandoned then, as it didn’t work and I had some jobs to get out.

When I came back to this (this week), I had read where FireControl didn’t recognize the THC ON/OFF commands and that FireControl would turn THC off simply based on the setting in the user interface where it bases it off a percentage of speed (defaulted to 85%). While I had seen this setting, I hadn’t paid any attention to it. Until now.

Diving back into the Path Rules, I removed the THC ON/OFF calls on the single Path Rule that I had created a few months ago. I was able to successfully slow down my cuts were needed (small circles and in corners), improving cut quality. This worked on 3 jobs. On the 4th job, FireControl would lock up or become unresponsive when loading the job. It didn’t (initially) cross my mind that the THC ON/OFF calls were causing this issue, as I had just taken them out and re-saved the Path Rule.

This is where I am still leaning SheetCam. “Where” it saves tools and rules… In their default settings. And in the jobs themselves. Still working on that. I don’t fully understand that completely.

In summary, once again removing the THC ON/OFF calls (that had crept back in) for my 4th job, solved the problem of FireControl locking up or becoming unresponsive.


When you exit Sheetcam, it will prompt you to save the job file and then it will prompt you to save the default toolset. If you don’t save the default toolset, it will revert back to the previous defaults and any changes you made will be lost.

1 Like

When I was setting up my tools in SheetCam, the prompt to “Save Default Toolset” was enabled. I left it enabled as I did my testing, tuning the toolsets for the materials that I was using.

Once I achieved a good “base” of tool settings, I disabled the “Save Default Toolset” prompt.

Does this apply to the Path Rules as well (the “Save Default Tool Set”)?

I’m not certain about that. I know that, if you open an older job file, it will apply all of the settings and rules that were present when that job was created.

Yes, I have seen that. And that may have very well been the sequence of events that happened before trying the 4th job. Brain is getting old. That detail is a bit foggy.

Thanks David - Jim

1 Like