Fusion 360 not showing Edit Function

I bought my Crossfire Pro over half a year ago and am now trying to use it. I downloaded Fusion 360 as non commercial. There are actually several issues with 360 that I have noticed. First, it does not let me transfer DXF files. I get a message stating I need to purchase membership to do it. Next, I noticed I have no Edit function as the tutorial shows. I have done the finish drawing and still no edit function. It is very frustrating to have to make a new drawing very time I have to edit it. And now I found out i cannot transfer files. I also tried to copy the drawing and it does not let me. It highlights but does not give me the option to paste.

Are you using open in the top left in the file system to open the DXF or are you using insert DXF from the tool bar? I recommend using the insert DXF tool.

964933eb6748791824969704bfa2dcc3786a3987_2_690x394 er

If saving a DXF you will want to do this by right clicking the sketch in the browser bar which running down the left hand of the screen and “Save as DXF”

Either right click the sketch in the browser bar and select " edit this sketch"

Right click on the sketch and select edit this sketch from the drop down

Select the sketch in the history bar along the bottom and select Edit this feature

@acardona73 Welcome to the forum

1 Like

Welcome to the forum. You’ll get plenty of help here.

I’ve moved your post to the Software/Fusion 360 category so it gets the right eyes on it (although @TinWhisperer is the de facto guru around here.)

I have ran in to this also. Sometimes edit is right where it should be, and other times its not. It’s very frustrating I know, but until you learn fusion inside and out (which I never will) you will experience things like that.
If I did not have so much time invested in fusion, I would go with something else. You might want to think about your other options for CAD software before you spend to much time with fusion to find out you don’t like it.

Spend some time looking at other CAD and CAM software programs before you decide what one you want.

1 Like

So, today I opened all my drawings and surprisingly all were able to be edited. I was able to save them as DXF files as well onto my desktop. Maybe today, Fusion decided to act as it should. I was able to use all the functions that I was not able to in the past few days. Now I’m wondering if its worth it to keep using it. Anyone have any suggestions for alternate programs?

By the way, thanks to all who have replied.

1 Like

I tried looking for all those options and nothing came up for me. The options appearing were very limited. But, today everything worked.