Fusion 360 not responding when opening DXF files

So I’m trying to cut some decorative things out that I found over on the Plasmaspider forum. I’m having an issue with opening them. Its taking forever and it will max out my computer’s cpu and goes into not responding. Just wondering if anyone else ran into this or is it my older Mac finally kicking the bucket.

Ill attach a file that I saved in fusion and see if anyone else has this problem. It seems when its 2D it struggles but if you can get it extruded its fine


How are you opening them? Uploading & then opening from the data window or inserting into a sketch from the menubar?

I’ve tried both only the upload then open seem to work. I try to insert but nothing happens

1 Like

Do you have a sketch active when trying to do the insert? I was just doing that last night & it was working.

Can you upload a file you’re having trouble with & I’ll take a look to see if I can see what’s up.


I uploaded it to google drive says its too large to upload here

Well it’s almost 4MB so not surprised the forum doesn’t like it.

My Fusion hangs as well. But I brought it into Inkscape - it’s about 22x14" right? There are over 17,000 objects in the design. My bet is Fusion is just either making slow progress or choking on it. Way more complex than it could be.

You can bring it into Inkscape and try to Simplify it or Join nodes - it’ll be a bit tedious maybe. I fired off the simplify and it’s cooking away. I’ll let you know if it helps. I do know DXF is pretty messy with lots of nodes when curves are involved. Might be able to convert it to SVG, clean it up in that format and then save it as DXF but it’ll take some experimenting to see what will work. I’m not sure how some of it will cut out - lots of small pieces - might end up having kerf problems too.

My PC is a Win10, i7 core chip, 12GB memory, 1TB SSD so it’s not a weakling, just a really complicated design. Which is pretty cool by the way :slight_smile:

1 Like

alright thanks for checking it out yeah I just wanted to play around with some new stuff but find its not liking fusion one bit Im running an older MacBook pro but its still got an I7 quad core chip 16gb of ram and 512gb of ssd so ya just amazes me fusion can’t handle it. I see a lot of people on that forum using sheetcam just wonder what alternatives there are for making the Gcode file.

It does load really fast in Sheetcam but I don’t know much about using that and I’m not sure if the basic Mach3 post would work or if we’d need whatever Langmuir did to make the post for Fusion.

It also loads okay into LazyCam (Mach3’s package) and it looks like there might be okay tool-pathing defined in the file (or LazyCam is making some decent guesses) but I’m way out of my element with these two packages. I’ve always used Fusion or Vectrix for CNC machining. LazyCam will generate a Gcode file with it that Mach3 can load but it’s 10,000 lines of code. You’ll need the full Mach3 license for it.

Don’t know if the Crossfire will run it though as I don’t have my table in yet.

Fusion is trying to load it so it can edit it. The others are more centered around the toolpath definition with far less edit capability so that may be one reason for the difference in ability to load.

I run into this with fusion at times its just fusion sometimes converting the dxf to svg and then opening in Fusion works or has for me when Ive had this issue

Good tip. Since Inkscape can open it, it could convert it to SVG on save. I hadn’t done that as I was letting it try to clean up all the nodes using the simplify function and it was clocking for that but I could see it was working as it grabbed resources.

Good idea I’ll have to try it. There’s just a ton of things already made over at the plasmaspider forum just would be nice to just import and cut without too much hassle.

1 Like

Yea there is a lot of good files on plasma spider, 3axis, and readytocut

Ive looked into Redpup which has a sign slapper software with dxf files and around 1400 images already designed . Does anyone know if you would have to bring the images into Fusion 360 to size since you can modify and size in its own software. Website states that its compatible with Mach 2 and a bunch of other controller software. Still trying to figure this stuff out before table gets here.

I tried this tonight. I could save it as SVG and then inserted it into Fusion. Slow response but workable. Still a fairly complex design but doable I think.

1 Like

Yea I had the same issue and fusion tends to freeze pretty frequently regardless of how fast your laptop is. Ive learned to use inkscape and 3d paint for most then import into fusion. I make a lot of mononograms with names and I add the name in inkscape save in 3d paint then transfer back to inkscape and trace bitmap so I don’t have to delete lines in fusion makes it ten times faster for me being I don’t have to wait on fusion

I use CorelDraw for most of my 2D work. Some Inkscape. Import it into VCarve or Fusion for the Shopbot or HighZ CNC. Probably follow the same workflow with the Crossfire.

The Redsail laser uses DXF mostly so that’s my Inkscape/DXF workflow. The Glowforge works best with SVG so that’s the Corel to SVG workflow.

1 Like

My fusion used to not even work, I was frustrated as I have a decent cpu but apparently it was saying my graphics card was an issue. Anyway, somehow it started worked thank the lord. But I do see it glitch out when I import some DXF files, I’ll have to do it a couple times. One trick I’v done is switch from model mode to cam and then back to model mode and the image has shown up.

Also all these files should be well under 1mb as they are just vector files. Even with thousands of nodes it shouldn’t get into the MB size.

I too use corel draw. Been using it for about 20yrs. I think inkscape is prolly a good choice even though I’v never used it. Working with vectors in these programs are easier than doing it in Fusion, esp with how slow Fusion can be. But I am happy with Fusion very much. Sheet cam looks pretty good too from videos I’v seen.

1 Like

I had that error on my laptop with 12GB RAM, 1TB hard drive, Core i7 CPU. Couldn’t do much about the graphics card (something Intel embedded on the system board) so I replaced the hard drive with a 1TB SSD (M2 format) and I don’t get the graphics card warning. I expect my disk based cache can now keep up where the hard drive was slow (5400 RPM).

interesting note. thanks for sharing

Where can I download lazycam. Or did it come with my full version of Mach 3?