I think it may be due to way curves are defined in the DXF. Inkscape and other 2D apps use bezier curves and you get a smooth line defining a curve vs a lot of small segments. DXF has a couple of ways of defining curves that matter - polylines and lwpolyline. Polylines have lots more segments and can be 3D. Lwpolylines have fewer segments so they’re more like bezier curves but can only be used for 2D designs.

When you save a file as a DXF you usually have to choose (it may be a default) if you’re exporting/saving with polylines (which does seem to be a default in most apps). That means when it’s inserted into Fusion you get a lot of small segments that the toolpathing needs to be defined for.

Yes, Sheetcam for creating Gcode…my process is this

Draw up project in CAD, I have been using Deltacad for 20 years now, cheap, easy to learn and fast for 2D…
OR create a DXF in Inkscape
OR download a DXF form any source

Then open Sheetcam, import drawing, select a tool (have made preset plasma tools), generate toolpath, Silulate if you want, then post to get G-Code and with your file that took about 3 minutes starting with saving you file.

I highly recommend trying Sheetcam, free demo here.

Then hit Youtube for tutorials here and you will be up and running in about 15 minutes!

What is also nice in Sheetcam is if you have any broken entities with just one click it will show you exactly where they are in your drawing. Nesting is a very simple process too.

If you download to try make sure to select “Mach3 Plasma” under Options/Machine/Post Processor as this is the post generator you need to talk to the Crossfire.


JHSome of the designs I use also are free clip art , free outlines/profiles and some purchased DXF files that say they are ready to cut and only need scaleing to your needed dimension
Even importing a ready cut DXF from a well known design site gives me same issues!

Some designs art png jpg bitmap traced into a svg
Tweaked and redesigned then saved as a DXF And SVG & or another png for later editing

Always have the segment issues

Even carbide create
A bare bones CAD/CAM Had no issues with the files.
Or Vetric aspire.
I imported the file into both and generated toolpaths and g code without a hiccup…

FUSION just seems to Suck
For simple 2D profiles anyway
For s simple 1.5” X 5.00” opener it had
30 chains in the contour selection
So many lines of gcode it Maxed out the line limit on MACH3 and only posted part of the gcode.

I am going to buy the full version but just wanted to run a few basic cuts to get the hang off the machine and software.

With FUSION that doesn’t seem possible though

I have to look at the Fusion settings because I saw what you’re getting on a design I’m cutting tomorrow - lots of segments. I do most of my own work in Corel but I was doing something new this week and got the lots of segments/chains issue but I just pulled through it so I could finish. Figured I’d go back this weekend and figure out what I had done differently this time so I don’t do it again :slightly_smiling_face:

If I figure it out I’ll post the solution because it’s seriously tedious having to pick all of those segments.

Thanks… I sat there after successfully importing the same design into other software I use for Cnc milling and had not a single issue with the imported file.

FUSION claims all over the ease of importing files , SVG, DXF etc… but I’ve yet to see it.

It should be a simple process for a 2D Profile cut,
I followed all the LANGMUIR tutorials and AUTODESK. Site tutorials as well
But the segments are a reoccurring issue every time…

I’ve become very proficient at design and editing in INKSCAPE it’s an awesome tool.

I’ll play around with the files here and there in FUSION to see If I can work it out
But I’m gonna look into Sheetcam…

Give the Trial version a whirl…

Deep six on FUSION


So I’ve dived in this morning and did a lot of research on FUSION 360 Forum.
There were tons of topics related to DXF import and SVG import on INKSCAPE and many other SVG editor software type including adobe, Corel draw etc…

I took a few of the Forum FUSION design groups idea of how to improve svg and DXF file imports into fusion and tried them.

The first and foremost one that seems to have solved the Problem of not having complete geometry to select was from saving the file from Inkscape.
When saving the DXF you presented with the following:
:white_large_square: use ROBO-Master type of spline output
Use LWPOLYLINE type of line output
Default seems to be the LWPOLYLINE option.
I unchecked this and selected use ROBO- Master type spline output
From all my research it’s seems FUSION needs the spline type ROBO output
Otherwise it creates multiple geometries around your sketchlines trying to assemble a com0lete geometry to match your import shapes. This results in the Bazillions lines of geometry you have select when toolpathing.
Also be sure your scale is in inches which is the next selection.

Also in INSCAPE WHEN YOU SET Your new document up
I now select file.
Document properties
Select all display units to inches
Orientation to landscape & units set to inches
Resize page to drawing selection
Scale is next and left at : scale X 25.4 user units per inch
Back round and border left as is
ONCE IN GRIDS you select NEW
Then I made sure that:
Snap to visible grid lines only
Were all checked
Under Grid units set it in inches
Then I made sure that spacing X & spacing Y are set to 0.250” inches
ORIGIN X AND ORIGIN Y ARE set or left at -0.0000
Last that the Major grid line every: is set to 1
Show dots instead of lines is unchecked
Hit X your done
When I import the files now in DXF
and the Coordinate is set exactly in the right spot on the plane face I selected in FUSION.

WHEN programming the toolpaths now so far selecting the geometries is one complete path now and not 30-40-50 chains for one 2” circle ,!!!,
So for now I’ve tried it 4 times on four different INKSCAPE DESIGNS
And so far so good.


Outstanding work. I haven’t gotten to my PC today to do any research into this and now you’ve saved me some time :slightly_smiling_face:

I’ll take a look at my Corel settings to see what they are when exporting (or Save As) DXF files. I use both Inkscape (some) and Corel (a lot) and was seeing different behaviors - sometimes curves and sometimes segments. Hadn’t paid any attention to which app I used to do the design in. This helps a lot.

Polylines and lwpolylines are both segmented line approximations in DXF to establish curves. Polylines tend to have way more segments in order to support 3D extrusions better. But lwpolylines are segmented too. Looks like the ROBO ones must be bezier curves.

I’ve bookmarked your post for my files :slightly_smiling_face:

Oh, BTW, the reason for the 25.4 scale factor is because I believe Inkscape uses mm as its native measurement system so this allows the correct conversion to/from your display & sizing of inches.

Also, just a heads up for non-Inkscape folks - by default Inkscape includes line thickness in its sizing of objects. It’s typically not a big deal but if you’re trying for precision and you use thick lines (I use hairline thickness) then it will impact your object physical size. The DXF and tools use the center of the line thickness as the definition.

Managed to get Inkscape running on my Mac, but the end file wasn’t much different - still had multiple segments for each element. Are you just saving the dxf file, or exporting? The file I’m working with is large with a lot of line segments. I’m currently running Fill Gaps on the file I saved from Inkscape since it did seem to have fewer segments. I’ve began to use Illustrator to help with some design elements which speeds things up. I don’t know how Fusion works, but sure wish it had a “join” function!


Save my design as a plain svg , DXF and also a png … SAVE all to specified Folders on my laptop.
And select them from there in FUSION

When saving as a DXF I deselect the LWpolyline
And selected ROBO-MASTER Option above it spline type output. Apparently FUSION users this kind of format in into software also called (R14)
I believe Inkscape version is R(12)

Also how you import the file into Fusion is also important
I start a NEW sketch
Pick Front XY PLANE
Then use the insert DXF option in top tool bar

Be sure all you dimensions are set the same as you saved in FUSION
I do inches…

I found the taking the extra steps to set up The document properties also in INKSCAPE
with Grids and resize to your sketch
And the scale at 25.4
Let’s my design insert into FUSION in the exact dimensions so designed it innINKSCAPE.

I setup 4 CAM models and toolpathed without the numerous geometry problems. I was having before.

Haven’t cut them yet but I ran the simulations and all looked great…

I just combined two issues I found on FUSION forums and INKSCSPE Forum
And so far it’s fixed both issues

Next steps are to try and save the files in Inkscape with both the LWPOLY LINES
And Robo-Master spline out boxes unchecked

And see what that does if anything

1 Like

Appreciate all your work and time into this. This file had many problems with lines not being connected. After following your instructions with inkscape, I saved as a dfx file. Then imported that into a new sketch in fusion. There were still many many segments so I ran the Fill Gap add in. After that, there were just a few places still showing segments, they were parts that had lines in the corners not even close to connected. Those I fixed by hand and now everything looks great! I believe they main reason your method didn’t work at first was due to the poor quality of my beginning file.

I’ll be printing out your instructions, thanks again!

1 Like

I think there’s some custom stuff happening there. The DXF format definition doesn’t actually support splines. I expect what’s happening here is that Inkscape ROBO gives Fusion some special info that allows the DXF to be interpreted without all the segment info that native DXF polyline format creates. The DXF format was defined a long time ago for CAD and is now being used as a general purpose file interchange format on way more modern systems so there are all sorts of things different software writers have done to make it modern-capable :slight_smile:

Most welcome

You can also find and fix these in inkscape very easily also.

I always check my sketch/svg before saving by changing the VIEW. To outline mode.

In this mode broken or incomplete paths are easy to see/find and fix using the numerous BOOLEAN functions available in INKSCAPE just like any other CAD …

Node editing and Bezier line tool are easy to use to join open segments as well.

When I am finished fixing any open path segments I
Save the file as usual . One thing I learned long ago with INKSCAPE is to
Reduce the stoke line to the absolute minimum.

For inches I set it at 0.002”
For mm I set it at 0.010 mm or lower

It’s difficult to see after that but CAD/CAM programs your sending it to like the small line width segments…
And having those set very thin is what the computer likes to follow for cutting.

Large stroke width can mess up your dimensions once you insert it into fusion

1 Like

From reading and browsing the forums there were numerous topics on these issues dating back to 2015

I was also running into the DXF file not inserting in the right dimensions also besides the numerous segment issues.

It was mentioned in one post about the ROBO-Master output type containing somewhere in it the code containing construction line data for the line segments in the design.
And that’s what resolved a lot of the INKSCAPE DXF import issues.
I don’t right code but it sounds good to me…

I stumbled across the file not importing into fusion in the right dimension due to some minor default settings in INKSCAPE .
A lot of it dealt with importing Text into fusion

Then later design files were having same problems.

Makinh these minor changes in INKSCSPE Doc. Properties has seem to work for me. For now!!

I’m still downloading and trying out Sheetcam
Watch some tutorials and seems really nice to use and made very user friendly in the flow in how it’s used.

Which I like. I think logical simple flow is the key to software use at least for me.

Which is Why I think Vetric software is best
Out there. The ease of use and logical flow made it a breeze to learn and use

Two really good recommendations. It’s amazing what you can see with the Outline mode - far easier to find breaks. Ditto on the stroke setting - I use .001".

I def want to try sheetcam. when fusion actually decides to work on my cpu its ok. I export .dxf from corel draw. I never have any issues with importing it. Infact corel doesn’t even give you line exporting options except it will ask if you want to convert fonts as line or text. It exports via autocad 08-13. I have version 17 of corel.

1 Like

With Sheetcam, you click on an icon and it will show white dots where every broken point is but you can’t fix them in Sheetcam, it has to be done in cad. Not a big issue as I will have Sheetcam open on one screen and cad on a second screen…dual screens are awesome.


What version of SheetCam do you get? The website is a bit confusing. I’ve just watched the beginning tutorial on YouTube and it looks like it’s much easier to select the correct tools and process GCode.


The Sheetcam TNG version I just starting getting into it more than just generating generic tool paths. Cut my first program today using some of the path rules where you can slow the IPM setting down by a percentage on things like small holes or shapes and inside corners to get more square inside cuts. Still have a lot to learn but with Sheetcam its a LOT simpler to learn these new things over Fusion and I have never had Sheetcam crash or lock up like I was constantly battling Fusion on.


Is this the limited version or the purchased version? It seems on their website that this is the limited version with 180 line max . I want to purchase the complete version. Is is like Mach3 that you download the trial version then upgrade and get the license sent to you?


Yes this download is the Demo, limited to 180 lines. You can download and install and then go to and on the side click Purchase and fill in the blanks, pay with Paypal and you will get a license emailed to you. Then in Sheetcam click on Help then Install License file and you are off and running.