Firecontrol visualizer doesn't work

I posed this several days ago on the main forum with no response… trying here again

I received my Crossfire XR in early June and have it put together and basically up and running. However, the tool path visualizer feature does not work for me in firecontrol. I downloaded the newest version of firecontrol, but it told me my computers graphics were not compatible and I needed to download the compatible version. So I removed that one, downloaded the .compatible version or whatever, and it simply told me that visualizer was not supported in this version…

I am using the computer that came with the XR…

Any help would be appreciated. thank you

you could do a windows update on the computer. it may correct a video driver issue?

Am running the most updated version available. Can’t find anything else.

I wonder if you could just reinstall the video drivers for your PC.

And there’s no updates available when you go to your Windows update?

I went through the same issue. Tried three different laptops, all several years old. Finally got a HP running Windows Seven to work by installing service pack one and the latest generic video driver for the video card, not the one issued by HP. Never could get a Dell or Compact laptop to connect to the visualizer although they work fine with every other graphics program that I have. I would gently suggest to Langmuir that they revisit their graphics implementation on the next update to Fire Control.

I recently had the same problem with a used but almost new Crossfire pro that I bought. Also was using a brand new Lenovo gaming laptop ended up deleting fire control and redownloading several times and hitting a bunch of different buttons and somehow got it working LOL. I am brand new to CNC and brand new to computers this is definitely a learning process

I will try that (reinstalling drivers)

I am a Mac guy so was already annoyed to have to use this PC… but I mean it’s the one they provided with the XR machine, doesn’t seem like it should be too much of a stretch for it work function properly along with their software…

What your experiencing is uncommon.

@langmuir-cameron will likely have insight and the answer to your issue.

1 Like

Have you installed the Graphics Drivers required in the manual? Step A4: CrossFire XR Assembly Guide | Langmuir Systems

These drivers should be pre-installed with future versions of the MC4000 Windows image but you may have received a MiniPC with the older image.


Yes, I had done that initially. However, just by clicking on a bunch of stuff, I discovered on the top left of firecontrol there is a “show visualizer” option… had not seen that yet. Would be a good item to include in the instructions to make sure that is turned on.


Can you take a photo of where this button is? I’m not seeing it. I have also updated the driver and reinstalled FireControl, and still no visualizer.

However, I plugged in my laptop with the same version of the software and the visualizer was on and working, so it is related to the PC that came with the unit.

1 Like

Well, not sure how I missed that. Thanks!

1 Like

thank you i didnt see it either

I have been running without the visualizer for months and just saw this thread.
I clicked “show visualizer” and it changed from the program percentage screen to the visualizer screen.
When I load a program, I still do not see any toolpaths or view of my drawing/desired cuts.
Everything is updated.