FireControl keeps crashing on startup

I had the exact same thing occur last night. windows was updating in background. I have windows 11. Firecontrol stopped mid run of a 40 min cut. Got the child process error message. could not get firecontrol to load again. I do have an AMD processor. I let computer update fully. Firecontrol still would not work so I found this thread last night and followed the instructions to remove firecontrol and install 21.1.5 compatibility version as well and it works fine again. Luckily i was able to salvage cut as well. This is irksome with firecontrol though. @langmuir-reilly


Turn that off. You don’t want anything running in the background while you’re trying to cut. You especially don’t want drivers & system files being updated during the process. There’s a reason you often see an update message telling you to stop running applications. Unfortunately, Microsoft is trying to make updates an invisible action so people won’t stop updating and ending up with machines that are running Windows and security software that is woefully out of date. The problem comes when the update impacts a running process (like FireControl) that it didn’t anticipate and it ends up hosing the app. You’re far safer to only do Windows updates when you aren’t doing anything else on the machine.


It’s off now. I had it off previously actually. I only even have internet access on that computer for folder Sharing between my design computer and the controller computer. I don’t like using jump drives but I make make a local file to share and only allow that computer to access the local network and block everything else on it.

1 Like

Google drive… You will love it.

i have the same problem now i have AMD 3220c dual core processor . i tried uninstalling and reinstall fire control no luck tried to update cpu the message said no new updated still fire control kicks out after a few seconds

This one was a head banger. Thank you ‘PatriotPits’ for your suggestion of installing ‘FireControl 21.1.5-compatibility’. This seemed to work for me, as well. I hadn’t noticed the compatibility version on the downloads but had downloaded the other ‘older’ versions and installed, with no success. I am finally back in working order after installing FireControl 21.1.5-compatibility. There seems to be more going on that just a single processor that’s being affected. Hopefully MS and Langmuir can get us a permanent solution.


2 days ago worked as will as it works with all the glitches the i live with. The ( Child error) and i have an AMD. Did all the uninstall and reinstall I can do with my IT help. I installed the older compatible soft ware was the only one i can get to open but it wont move the torch. Help money to be made?

Try rewording your post, not sure what help you are needing

Anyone find a solution. FireControl is POS.
Today made one good cut. Little too much Dross, so edited the drawing and changed the speed, Repost a new file. Loaded it to FC. FC stopped on pierce. After that, FC no longer worked. I did get that dam Child Error. FC was not responding, so shut everything down. Relaunched FC, and nothing. Just a grey screen. No connection to anything.

Tried uninstalling and reinstalling, nothing.
Tried shutting everything off, and restarting everything. Nothing.
Three different USB cables, Nothing.
Tried three different USB ports on the PC, nothing.
Check device manager on pc, no errors. When I plug in the USB cable, the PC beeps. Like it should. But nothing with FIreControl.
I have a Window 10 PC, intel processor, No update of OS resently. And it worked on first cut, but quit on second cut. When second cut stopped, so did FC. No errors showed as FC just stopped responding. Locked up. Had to force shut down. then Child Process Error box.
Already sent message to Langmuir, no response at this time.

Are you sure your post processor is not corrupt ? Child process means its getting incomplete or invalid data. Fusion or sheetcam? Try reloading your post processor …


First…calling Firecontrol POS is like catching flies with vinegar…not very helpful.
We understand frustration but coming in and calling the software crap makes people hesitant to help you…just saying…

Now to try and help…by doing a search for “child Process” and using the magnifying glass search function I found what might be some help for you.

properly unistall Firecontrol…restatrt system…then dowload and run this version of Firecontrol…

see if that works…if it does please come back and let us know…if not then expalin what happens…

good luck.


Im just calling a Fly a Fly. What ever.

First, I am running Compatibility in my laptop. Same problems. The PC is running 21.1.5 current version. Same problem.

When I looked back at the drawing, created in Fusion 360, I edited the drawing to correct an error in design. First I deleted the profile, setups, NC Program everything until all I had was the sketch. Edit my sketch (which Fusion has issues with) Redid the setup, Redid the cutting, then created the g-code, like it should be done. I am guessing the PP was reloaded at that time. But I was having problems editing an existing drawing in Fusion. So that may have caused the corruption in this situation. But I am having the same problems when I just repeat the same cut. Make one cut, good, move torch to new location, re-zero, press start and the problems start all over.

So here is more process after the last rant. Sent message to Langmuir for this and more issues, waiting for their response. Took my laptop, connected to machine, started FireControl. Get message to update from 1.3 to 1.2, I think that is actually called downdating. Other forums mention this problem so I just ignored. Clear problem with FC. Anyways, it connected to controller. Shut down and moved to PC. First problem, no connection. Then message from windows “USB device not compatable” or something like that. Tried 4 other USB port, all that have worked in the past, eventually connected to a port that worked. A port that was tried before and failed. Now that the port was connecting, I launched FireControl and it connected. Opened the NC file and ran, FAILED. Again, torch would fire then stop, and FC would stop responding. Unplug, shut down, close , restart, replug, same-o-same-o, same result.

As a final test, before I really though a fit. Got everything running again, but this time I turned off THC inside of FireControl. Ran without a hitch. moved torch to new location on sheet, re-zero, ran again without a hitch. Two pieces cut, no issues, THC turned off. Inside Fusion, when posting, IHC and THC are turned on. This could be the problem. A conflict with Fusion having THC on and FC also having THC turned on. Maybe?? Which would mean both Fusion and FC are POS.

I can’t say the problem is resolved, it just work this time. I have cut two other pieces, same sheet, same setup, and they both cut just fine. Only difference, running FireControl 21.1.5 Compatibility on my laptop. And THC was turned on. Why would 21.1.5 on the PC be different? or cause so much more problems? Maybe I don’t need the viewing window. Or maybe FC 21.1.5 does have issues, and is crap.

BTW. I think all all electronic computer controlled stuff are crap, PC, window OS, Cell phones, Cars. Anything with a computer . Rubbish. Just deal with it.

This comment may shed some light that you don’t have the patience for this kind of stuff.


It looks like you have gotten the machine back to the state where Langmuir was trying to root out v1.3 that had some information that was not playing well with limit switches. I would suggest allowing the machine to update to v1.2. Once it restarts, it will then ask you to update to v1.3. [You may need to turn the control box off and then on again to allow a full restart of FireControl.] Do that update, as well. Apparently, they have two versions of the v1.3 or that was the only way to get rid of “something” in the one version of v1.3. Somehow that is a “workaround” the techs found to deal with a problem in the software.

I know it sounds crazy that you have to do this but it seemed to fix my issues at the time.

Obviously, some information is not flowing over to firecontrol. I would still consider the update of firecontrol. The handshake between the programs is not dovetailing correctly. FireControl should be honoring you selecting THC on or off. If it is not, then you know there is a glitch there.


I might wrong here but, the Intel processors that end in U are almost always in a laptop.
They are low power consumers that are used when batteries are a primary use.


Yep! Same with the AMD “-U” variants; these power-efficient models are great for extending battery life, but unfortunately it looks like Windows is suddenly confused about how to handle them.

This is compounded by the fact that CrossFire users generally find an affordable laptop to dedicate to the machine completely, and computers equipped with AMD processors are usually a bit cheaper than their Intel counterparts.

What’s interesting is the small percentage of “-H” variant AMD models we’re also seeing have this issue. These models are less efficient, higher performance, mobile Ryzen CPU’s. Seems like they may use some of the same power distribution protocols as their “-U” cousins.


Hey everyone,

I recently encountered a frustrating issue with my new computer and a fresh FireControl installation. After some troubleshooting, I managed to resolve the problem, and I wanted to share the solution in case anyone else is facing a similar problem.

The Problem: I was consistently getting the “Child process exited with code 1” error message when trying to run FireControl on my new computer. Despite uninstalling and reinstalling the software and trying different versions, the issue persisted. I even attempted to use an older version of FireControl, which didn’t give me an error message but also didn’t open.

The Solution: After some trial and error, I found a solution that worked for me:

  1. Java Version: I realized that the issue might be related to the version of Java installed on my computer. My system was using “1.8.0_351.” I decided to download an older version of Java compatible with FireControl.
  2. AMD Driver Update: I also thought that updating my AMD graphics driver might help, as sometimes software conflicts can arise due to outdated drivers.
  3. Compatibility Mode: I gave the latest version of FireControl another shot, this time in compatibility mode. To my surprise, it opened without any errors.

Step-by-Step Fix: Here’s what I did to fix the issue:

  1. Uninstalled FireControl completely.
  2. Downloaded and installed an older version of Java like “1.8.0_351”
  3. Updated the AMD graphics driver to the latest version.
  4. Installed the latest version of FireControl 21.1.5-compatibility and open it.

Download: Java : jre-8u351-windows-x64.exe

Conclusion: In my case, the problem seemed to be a combination of Java version and AMD graphics driver issues. By downgrading to a compatible Java version and updating my graphics driver, I was able to get FireControl to work without any errors.

If you’re encountering the “Child process exited with code 1” error or similar issues, I recommend trying these steps to see if they help. Remember that software compatibility and driver updates can often play a significant role in resolving such problems.

I hope this solution helps others who might be struggling with a similar problem. Feel free to ask if you have any questions or need further assistance!

Best regards,


Nice Job explaining what you did! Thanks for posting

@jsvalentin welcome to the forum.
great of you to post your work around here…every little bit help everyone.
You are obviously very computer literate…

if you had come here sooner and searched for the issue you might have found some help to speed your solution along…
I am going to tag @langmuir-reilly on this so the folks at Langmuir can read what you have done and possibly comment on it or add it to thier other solutions…