FireControl is showing no connections

FireControl is showing no connections

Are you using the provided USB cable?

Have you tried to manually install the driver?

Does the green light on the back of the electronics enclosure near where you plug the USB cable in come on?

Have you tried other USB ports on your computer?

I am using the provided cable
I do not have another cable like the one supplied.

I have tried to manually install the drivers but think this may be my problem.
I’ve tried different USB ports and hear my PC chime when I plug or unplug the USB cable
And the green light on the electronic box is on.

I dug a little deeper and it looks like the drivers are not installed. The link I found on the support/download page that I’m downloading isn’t the driver but a document that is opening in Notepad???

You could try a windows update.

I am not sure . can you provide a link to the one you are trying to use.

1 Like

try to uninstall your current driver and windows will try to replace it.

. Currently the green light comes on the electronic enclosure but doesn’t light up in the top right corner of fire control ?

1 Like

I think that is my problem is I’m not finding the right driver to download. I know how to go into device manager and install uninstall or update drivers. My problem is I don’t have the correct driver to do the install

Do you have window 7? The drivers are not signature driver through Microsoft. There is directions how to bypass the signature.

1 Like

The green light on the elec now where it cable plugs in is illuminated but not on the PC screen

I Have Win 8 Seems my problem is finding the correct drivers

I think it applies for windows 8 as well I have used the same drivers on 7 and 10. I had the exact same problem you have. My windows 7 even went through the install process which made me think it had until I looked. There is a link on the download page to manually install. It give directions how to bypass the signature. Fire control does not have a Microsoft signature. The older versions of windows will not let it install.

Click on installation instructions

right click on the file you downloaded and there should be an option to "install’ on the list. that’s how you install drivers that end in .inf



Thanks I’ll look at that when I get home this evening

1 Like