Firecontrol Errors with XR

Definitely reach out to Support above ^.

We would need to see the program to determine if there’s something going on with the particular file or line where it continues to fail.

I can offer some insight into the pierce delay issue you are seeing as the XR Pierce Delay is calculated differently than the PRO or CrossFire Pierce Delay. The XR system (MCB/THC/FC) features a voltage feedback that starts the pierce delay “timer” when arc voltage is sensed rather than simply starting after the signal is sent as is the case for PRO/CrossFire. This should bring most pierce delays for XR back in line with “book” delays and is why you are having to reduce the delays from older programs.

1 Like

Yes I am familiar with why the pierce delay differs. As much as I wish I could keep 100% seamless files between both machines I can deal with this.

The program works absolutely fine on the PRO for many many months, works sometimes on the XR and sometimes it hangs up on 1 particular hole. Im goin to re post process it and see if that helps.

Is there any issues with slightly older sheetcam vrs their newest? I honestly don’t know what version of post processing I have but again it works on the PRO.

5th production day today. 1300 pierces. My file that would randomly give me an error on one hole (would pierce and shut off, if I skipped that hole rest of file cut fine), I re post processed it. Today I cut that file twice and had no issues. Now the other file that gave me the same error ended up doing it again today. I had already re post processed this file. Outta 12 plus files I cut a day, its only ever been 2 files that give me the issue. I had no issues with them on the PRO. I’ll keep updating.

Still having this random motion control error and its starting to drive me nuts. 232 holes in this sheet and 1 wouldn’t cut. It would pierce but then give me the error. I just make this file, so not sure if its a post process error or an actual machine error etc.

Is it that lower right corner? Are you hitting a limit switch or binding a cable?

This particular error was still plenty far from limits hitting. It was last hole right where the machine homes.
Its definitely not bc of the limits, they will give you an alarm error anyway. This is a very random issue, happens atleast once a day pretty much.

@langmuirsystems @langmuir-cameron The lack of customer support is becoming an issue for me. Im on my 5th and most likely last machine I will buy from you guys. I emailed last week with a file to have you guys look at, no response. This is second time now, just nothing. Not much feedback on the forums anymore. FB is way too cluttered and alot of newbie stuff on there, so I don’t go there for help.

Today not only did I get this pesky motion control error (pierces and stops) will not recut for the life of me. Well FC decided to freeze twice today. First time this has happened. Im on day 7 of actual production with the XR. I still have little confidence in this machine. Aside from the Y axis sounding rough as heck, my biggest issue is now the electronics. Iv had tons of ups and downs with the PRO but after some of the bugs were worked out, I didn’t have freezing issues for a long time, its probably more reliable right now than the XR.

I restarted computer bf I started cutting, had it freeze within 5 cuts, completely ruined my part bc it lost the zero coordinates, second time it happened I homed machine but it still lost zero coordinates bc of the freeze. Then after another restart, hours later I get the motion control error on a file I had previously cut in the day (so its def a random issue). I changed my cords up and then made sure the CNC usb was plugged directly into computer rather than a usb hub. Only thing I can think of is my computer is 5ft from the plasma and the plasma is 7ft from the CNC controller. I will be changing this but that is the only thing i can think of for these issues.

Out of 7 production days, I might have had one flawless day. Its just the same thing over and over with these machines, something mechanically hangs me up and or something with FC hangs me up. Im finally going to buy another machine from someone else this year. Was hoping to get a year or two out of the XR but at this rate I don’t forsee that at all. The amount of down time is just unreal right now.

I will seek this support message and program out and respond properly ASAP.

Regarding the freezing (apologies if this is explained in the aforementioned message): You seem to be using another computer to control your XR-not the MC4000. Just to be sure- are you using the USB isolator provided when using the XR?

Im using the computer supplied with the XR and Im using the isolator yes. I have the controller box cord going into isolator and now going directly into computer. Before I had it going into a usb hub.

Responded via our ticketing system!

Im having the same issue with my XR right now. FC keeps freezing during the cuts. Cut three quick signs today and 1 i had to recut twice because the software keeps freezing mid cut. Im debating on ditching the pc that came with the XR and trying my laptop.

Are you running the latest version of FireControl? Early versions of 21.1 had issues with USB connection issues that were fixed with the current version available for download.

It’s 21.1.3 I’ll upgrade this weekend and see if it helps. Thanks

I only got the freeze on 1.4 update so for me I’d rather go back to 1.3 which I may do if I get another freeze. I know LM is working hard on this stuff but its been way too long dealing with fixes and updates for me. Way too tight of a schedule for some of us and metal is still super inflated. I was not expecting this on the XR. Hope it can get resolved. @langmuirsystems can we install FC on a laptop and still run old version too? Example I use a laptop on my PRO, say I wanted to put the newest FC on it also, is that possible or will it just always override the existing one?

I have both 20.6.2 and 21.1.4 on my laptop. They are separate installations and I can open either one.

A few people on the forum had issues with thinking their computer wasn’t updating and they didn’t realize the new install doesn’t remove the old one. They were still clicking on the desktop icon for the old version and wondering why it didn’t update.

thats good to know. Im pretty good with understanding programs and installs etc. However this XR supplied cpu was just weird on the update I did to 21.1.4 I wasn’t sure it even worked but it does say it when FC is open and now this version doesn’t offer the “high Priority” option. The 1.3 version offered that and it would make a special link on the desktop so when you opened it, it basically did something to the effect of keeping memory or something reserved for FC while its running. I may put this on my laptop and see if that doesn’t help.

@langmuirsystems I was reading on cutting edge plasma where they state this “Our motion control software MyPlasm CNC has a few key features including sending G-Code to the control box before starting the cut. This feature gets rid of the issue of any interference from the computer during the cut.”

1.Is this something you guys are aware of, do or would consider in the future? assuming its not incorporated now and the control box would need some sort of hard drive on it to keep memory?

2.Is an interference issue something that makes FC "freeze"or is it more a program or computer issue?

You are seeing the buffer getting clobbered and sticking a few unusually long Gcode lines together which result in errors as the combined line doesn’t make ‘sense’. We are attacking this issue in a few different vectors at this point and hope to have a resolution soon.

  1. They likely use flash storage. Our system does not work like this and does not limit the size of program you can run. We’ve successfully run multi-gigabyte programs with our software and electronics.

  2. Generally yes. If the plasma cutter is running, it is usually interference interrupting the USB connection.

Responding to your support message presently.

I got about 40 min cut time in today after I talked to cameron on phone. I made two new files bc Im trying them with a cut at .04 rather than .06 to make up for the backlash to see if I can reduce some taper. So I took two of my files and changed that. I restarted the mini pc, fired up FC.
1st file was about say 9 min with 80 pierces. I got a motion control error with about 4 cuts left. I finished program and for kicks, restarted FC and ran that hole that wouldn’t cut. Well it cut. I also took another file that I know had an error on one particular hole, and today it cut after the restart.

So I highly think something is wrong with my actual control box and or something with FC and the mini PC. Im leaning more toward the control box because Cameron said this is a very rare error.

I cut a total of 4 files today totaling 40ish min of cut and 300 pierces. Motion control error was all I got.
I moved PC farther away from plasma. Thankfully I got no freezes in FC today.

Other notables.
I did notice the USB end on my dongle is bent.
I am running a wireless keyboard and mouse
Im still running the very original THC (not the new one supplied with the XR)
It seems as if all the motion control errors Iv got were on holes, most of which have a rule set on them
I am using sheetcam and from my experience that generates less lines of gcode than fushion
Im using Hypertherm XP 65 (Cam also said all these freeze issues are with Hypertherm guys)


although this is interesting is is not on topic with what @directioneast is dealing with.

many of us would like to read about this more…but under it’s own thread.

I have asked the Mods to move this to it’s own thread unless you are able to do it first.

1 Like

cameron has been making efforts to help me and is working with their programmers. For the motion control errors they are working on an update for sheetcam post processor. What I find strange is I never had these issues on the PRO.

Today was an average cut day about 1200 pierces in course of 4-5hrs. I didn’t get any motion control errors and thankfully no FC freezing. However I restarted my computer atleast once and I restarted FC about 4 times during this span just to be safe.

What did happen was when I restarted FC the one time it wouldn’t pop up (btw its really slow opening on every start up). So I double clicked it again and it says it already opened. So I had to open task manager and shut it down. Then when FC opened I get the prompt that says “set fire control as high priority” something that use to pop up on the 1.3 version. So I did that and reopend FC which now has the “high priority” logo in green. No idea why all the sudden its doing that and no idea why FC didn’t open properly.

1 Like