FireControl crashing in macOs 12.0.1 Monterey

Anybody else having issues with FireControl 21.1 crashing after a minute or two on a Mac with Os 12 Monterey?
I have other computers running older OS’s to run it from but is this a known issue with OS12?

I will say that FireControl seems to be stable if the usb from the plasma, a crossfire pro, is disconnected. I’m unable to load file but it’s not crashing.

I take that back

I’ve been holding off upgrading to Monterey on my MacBook. I don’t regularly use it for Firecontrol but I do have it as a backup. Have you been successful in getting it to run or was it a no go?

Just curious :grinning:


Oddly enough I tried it today and it worked out just fine. No crashes.

We have not tested FireControl with MacOS12. If there are issues, they are likely graphics or device (USB) related. Its possible Apple has updated drivers over time and added additional support for graphics libraries.

Thanks for the info! I’ll give it a go and see what happens. I only use my MacBook as a backup to my windows laptop for cutting so if it does give issues with FireControl not a big deal. I’ll update this thread if I run into any problems. :crossed_fingers:

Results are in for my Monterey upgrade on my Intel MacBook and FireControl 21.1.3.

No crashing (although I initially started my old 20.6 install instead of 21.1.3 and it crashed). The test cuts I did ran fine. Visualizer looks good although the cuts and the fast moves are all the same color. No biggie. So I think I’m good.

@langmuirsystems FYI

Mine crashes from time to time. Never while running the app though.

I loaded the 21.1.4 Beta a couple of days ago (live dangerously i say :laughing:) and things seem to be okay so far. No crashes and fully functioning so :+1: for me.

1 Like

At the risk of bringing a thread back from the dead, i’m running Monterey 12.2.1, and am having the same issues - sometimes the program will be fine thru multiple cuts, other times, it will poop out in seconds, and occasionally in the middle of a cut. I can’t really identify any strongly correlating factors. Oddly, it seems to get more stable to more I have to re-open it.

Any common experience here? Running the same cuts twice kinda stinks.

I’m on 12.3.1 and FireControl 21.1.5 now. As I said previously I don’t use it as my primary cutting platform but had to use it for a bit recently when my Windows box had a hardware failure and had no issues during the few days I was using it with Firecontrol.

2015 MacBook with 16Gb of RAM and the 2.7Ghz i5

Yeah. It’s not worth the risk on a high dollar cut. I take back what I said earlier. It crashed on me mid cut and that was it. I draw the parts on a newer computer with fusion and cut on an older computer. Both are Macs but one runs an older OS and fire control with no issues.