FireControl connection lost mid job and throws Java Null Error (solved)

When running a job, usually a longer one, I get an error from fire control, see below. The software then looses connection with my machine and the job is a total loss. This has been so frustrating and has cost me a lot of money in wasted material. Has anyone had this error and figured out a fix?

My PC is a Dell Precision M6800 with a intel i5-4200M CPU and i’m running windows 10.

I have a few other CNC machines and I dont have this issue with LynuxCNC or GRBL. Is there another Gcode sender I can use instead of FireControl?

java.lang.NullPointerException: Cannot invoke “com.langmuir.cnc.core.base.device.module.ThcConfiguration.isVersionWithErrorCode()” because the return value of “” is null
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
at java.base/ Source)

I will add that this issue seems to happen during a G38.2 command, probing prior to pierce sequence.

I created a ticket with Langmuir a few day ago but still no response. Here is a video of it in action, the video is a bit long so you can fast-forward to the end to see the failure. I wanted to show that this does not occur on every probing command and appears to be random. As you can see from the sheet I’m cutting on I have attempted this job many types and it fails in different points of the code every time. It always fails during the G38 command when the IHS is triggered.

Video of Null Failure in action

I noticed that when this occurs the system goes from RUN to HOLD:0 state. At this point everything is frozen. I was able to reproduce this “HOLD” state by actuating the IHS many times. Then if I disconnect and reconnect my machine via the USB I also get the null pointer error. See video of that below.

Manually reproducing the failure

Long story short I have no idea what is going on or how to fix it. I’ve tried the easy stuff like power cycle, new firmware, update fire control, etc.

I did watch the video.

It sounds like your compressor never stopped running the entire video.

Could you be running short on air?

And Welcome to the Forums

The compressor is capable of 6.2 SCFM @90psi which should be adequate. Now that may be right at the limit with continuous flow. I’m not sure how that could be related to my issue though.

Thanks for the reply. I was beginning to think I was talking to myself.

Make sure IHS switch is clean, wires are tight, and switch isn’t touching z axis screw.

1 Like

I ve never see the IHS HOLD NULL FAULT before.

Maybe the eccentric bearing are too tight on the z axis?

@langmuirsystems does Firecontrol automatic throw a hold command on the IHS when it is triggered erratically?
Turn the IHS light yellow in fire control?

1 Like

I have disassembled the entire z carriage and cleaned everything and I adjusted the eccentric bearings so there is no play but also moves freely. I cleaned the copper contact on the IHS many times. I have started cleaning them with a Q-tip and acetone prior to every job but still not luck.

I tried using a newer laptop and that seems to have solved my problems. No more null error or Hold state.


Great you are up and running again!

maybe try updating the USB drivers of the old laptop and see if it clears the issue?

Weird issue, would be nice to pinpoint the cause.

Thanks for keeping the forum updated.

Yes I’m up and running again and I finally cut out my sign without issue. The newer PC is a Lenovo running an i5-7500U and windows 10. I’m also running the newest version of firecontrol on this machine which may be the difference. My other PC could not support it graphically and recommended I download an older version.


Are you willing to post that file on Fireshare? I have a boss that would love that.