FireControl compatibility version?

I just installed FireControl I got a message in the app saying that I needed to install the compatibility version? I’m trying to run it a on Dell slightly older dell laptop (about 6 years old with an Intel i5 processor) with Windows 10 (fully updated). Anyone know what triggers that message?

Yeah. Your graphics card can’t support the normal version of 21.1.5. It may run, but the preview window won’t display anything. The compatibility version works with older or integrated graphics cards.

1 Like

Uggg. The laptop has a discrete gfx card that seems like it should be supported. It’s a NVS 5200M which supports OpenGL 4.6, DX12, and from my reading is roughly equivalent to gtx-630M. That seems more than powerful enough to run FireControl. I don’t like the idea of buying a new laptop, but maybe I don’t have a choice now?

You don’t need to buy a new laptop to run Firecontrol. You can try to run the standard version and see if it works, or you can run the compatibility version. There is nothing different about the compatibility version, except the display graphics.

If you want to run Fusion on that same laptop, you will probably need a new one.

1 Like

Ahh, ok, I’ll give that a try. The “compatibility” version is randomly crashing on me when operating the THC so I wonder if it wasn’t updated recently? I have a much bigger desktop I use for my modelling. Thanks for the help!

Well, I uninstalled the compatibility version, and tried the normal version, and it didn’t work. So even though the laptop does meet the requirements, it doesn’t seem be supported.

What table are you using? If it’s the standard Crossfire or the pro, download and use Firecontrol version 20.6.2. I’ve been using it for a while on my pro with a mini PC.

1 Like

Oh, I will try that. I’m using the Standard Crossfire that I’ve have for maybe 2.5 years now? It’s old enough I’ve been using Mach3. I just bought the THC upgrade for it so I put the new controller box and THC on the machine and am trying to get it to work. I hate to say it but it’s been a pretty miserable experience. Enough that I am contemplating ripping the THC and controller box off and sending it all back. Mach3 was dated, but it works, which is the opposite of my experience with FireControl so far.

I’ll try 20.6.2 and see if that helps.

Ok, now I’m playing with literal fire. Dropped FireControl back to version 20.6.2 and it fixed everything. Thank you for the advice @ds690 !


Glad it worked for you. I’ve been sticking with that version, because it works with very few errors. I see too many people having issues with the newer versions.