FireControl 21.1.4 Beta Release

We are soon to release a minor update to FireControl to address some issues and bugs noted in the last few weeks. This is a minor release with no major updates to the core of the application but with fixes for specific issues.

Updated in 21.1.4

  • USB connection stability improvements
  • Metric Program Speed Fix
  • Machine Setting: Max Rapid Speed - depending on your machine (XR vs PRO/CrossFire) you can limit the max XY speed of your machine via the Machine Settings menu.
  • Other minor bug fixes.

We ask that if you have been having issues with any of these items (or not) to check out this new 21.1.4 version. While we test FireControl on many different types of machines, USB issues in particular depend greatly on individual machines so the more users we can have using it the better.

WIndows
https://assets.langmuirsystems.com/firecontrol/latest/FireControl-21.1.4.msi
https://assets.langmuirsystems.com/firecontrol/latest/FireControl-21.1.4-compatibility.msi (for older graphics)

MacOS
https://assets.langmuirsystems.com/firecontrol/latest/FireControl-21.1.4.pkg

1 Like

Neither the current release or the compatibility release will work with my laptop. I’m very frustrated as I made the mistake of updating and now I no longer have a working plasma cutter. Will this fix it?

1 Like

You have the option of downloading 20.6.2 in the downloads section.

Thank you for pointing me in the right direction. I was able to download that version and get it working on WINDOWS 7 laptop…

It really pisses me off that they pushed an “update available” through fire control that downloads an incomparable version!!! They they take you through the rabbit hole of suggesting an incompatible “compatibility” version.

Do they not know how to do a simple OS version check?!

Stupid…

Even their post above says nothing about not being compatible with windows 7.

Once again I am now angry they did a bait and switch on me. I bought my pro table when it was supposed to come with Mach3, but they switched it Firecontrol and I’ve been their damn “learning experience” ever since.

1 Like

We apologize for the trouble you’ve had.

There is nothing about Windows 7 that makes the latest versions incompatible. Most Windows 7 computers are around 10 years old (or older if they were updated to 7) at this point and have older components which can lead to incompatibilities usually surrounding graphics.

We try to develop FireControl in a ‘greatest good for the greatest number’ manner but sometimes that leaves older computers behind.

1 Like

If there was nothing incompatible about the latest version with windows 7, then you wouldn’t have a windows 7 version on the download site.

Accountability seems to be a hard concept these days.

Dude, I have to respectfully disagree with you about accountability.

In my experience with Langmuir they have been really good about about dealing with some of the issues as well as giving options for me with the new version of Firecontrol. Having been in software testing I know that most software vendors try to keep backwards compatibility for exactly your situation which is what Langmuir has done but you can’t be compatible with every piece of older technology.

I figure what you’re asking for in computer terms is the equivalent of asking them to supply OEM parts for a 39 Ford because you have one.

Anyway. My dealings with @langmuirsystems regarding Firecontrol have been great. Sorry yours haven’t been as good.

Hope the rest of your year and 2022 are good to you.

4 Likes

HAHAHAHAHAHAHAHAHAHAHAHAHHAHAHAHAHAHAHA !!!
Thank you Bob : )))

2 Likes

I would bet that the compatibility problem is hardware related, not OS related. There’s lots of options, but running an older version of the software, so you can keep your 15 year old laptop instead of spending $50 to upgrade to a newer better one, is not a great option. Just my $.02

2 Likes

I upgraded to FireControl 21.1.4 on my MacBook Pro, Big Sur. I find that on loading the software, or a new cut file, FireControl goes into HOLD status. To clear it, I find I have to act like I’m going to run the code, get an error, and choose “reset” in order to get the status to be ready. It’s fine until I load the next code to be cut, then have to do the above again. Is this a feature or an error? What’s the correct procedure to move from hold? I use SheetCAM to create the g-code. It’s beta, so maybe I’m reporting an issue!

This sounds like a firmware issue or electronics issue. We have not been able to reproduce this on our Mac machines.

Were you able to run older versions with success?
Can you provide a video or some screenshots of what is going on?

I was able to use older versions without a problem. As it turns out, it seems that this issue only happens when I use SheetCAM instead of Fusion360 for CAM. First video shows a file opened in FC from SheetCAM, and HOLD as a status, I then run the code in FC, get the error and use “reset”. This sets the FC back to “idle”. Second video, shows different files, same result with the SheetCAM coded file. So far, the added step is a minor nuisance. (Sorry, can’t upload videos here and don’t have my own website to host them.)

Can you post the programs for each? Sounds like this is related to the code itself.

Camaro and Batman are SheetCAM codes. MyKitRules should be Fusion360 code.
Camaro1525A16Ga114ipm62CH4P15PHthcSC.tap (30.5 KB)
BatManEmblem25A16Ga114ipm62CH4P15PHthcSC.tap (35.9 KB)
MyKitRul27A16Ga90ipm6CH6P17PHthc.nc (34.6 KB)
Thanks for looking into this. Hope my logic helps track it down.

The problem is those additional THC off/on commands in the Sheetcam file.

I don’t know how Firecontrol treats a semicolon (end of block) command, but it may treat it as a stop and wait for a command to run the next block.

It’s not necessary to add those additional THC on/off commands, since the software turns it off automatically when the torch speed is below 85% of the program speed. Remove the path rule or code snippet that is adding those commands in Sheetcam.

Thank you. I’m learning sheetcam and some tutorials just go a bit over the top with rules. Thanks for looking into this and sorry for the troubles. Happy New Year!

1 Like

new version does not update. Still shows 20.6 after running and “update available” in Fire Control. uninstalled Fire Control and reloaded - same result

It installs in a different spot so there’s a new shortcut for it. You can use the new one and 20.6.2 on the same machine.