Fire Control Software error messages

I have been trying to load the Fire Control software onto a Panasonic CF30 laptop running Windows 7 Professional. I have not had much luck in this process. I have tried to load the 21.1.5 and 21.1.5 - compatibility versions. It loads onto the computer with no issues but when I try to run the software on the computer I get the following error, “The procedure entry point ucrtbase.terminate could not be located in the dll api-ms-win-crt-runtime-|1-1-0.dll.” When I click on the OK button this error will keep popping up three times and then the following message pops up, “Child process exited with code 1”. when I click the OK button on that error the program closes.

I have tried to load the same software onto another laptop that has Windows Vista but can’t seem to get that running either. The software will not load onto the computer with an error message saying the package is not compatible with the processor. I think that might be because the Vista version seems to be 32 bit but not sure.

I would appreciate any advice on how to get one of these to work with out having to buy another computer. I’m trying to get the Vista machine updated to Windows 10 but that is going to require some other updates before that can be done and I’d like to at least finish up getting the table setup.

Welcome to the forum. I moved this post to a new category, but probably we should add @langmuir-reilly to the distribution list.

Hey Ward,

Does your computer happen to have an AMD processor? If so, which model specifically?

We’re aware of a very rare issue with a recent Windows update that causes this OS-level error when trying to run FireControl. It seems like the Windows update introduced a bug that is affecting certain processors. One user was able to resolve the issue by simply uninstalling and reinstalling FireControl - other have found success by updating their CPU drivers or computer’s BIOS. Keep in mind that the latter two are relatively drastic steps.

Unfortunately, due to the rare nature of the issue combined with the fact that it stems Windows - not FireControl itself - at this time all we can do is provide suggestions that might work and collect data that may help us formulate a consistent fix.

There’s also an ongoing thread about this issue that I’ll be keeping updated whenever we get new information:


The windows 7 machine is running an Intel Core 2 Duo CPU L7500 @ 1.60 GHz with 4 GB of Ram. The computer is a Panasonic CF30. I have removed an re-installed the Fire Control a couple of time and I keep getting the same error messages with all.

I’ve been trying to work on this issue over the weekend and have taken a baby-step forward and then I found another unrelated problem. First an update on the software issue. I worked this problem most of Saturday, Sunday and found the following:
• When I attempt to load the Fire Control software v 21.1.5 , 21.1.5 Compatibility, and 21.1.4 the programs loads in the C:\Users\user\appdata\Local\FireControl directory and not into the program directory. The program crashes on startup. I originally thought it was giving me the same error messages several times before it closes but I was mistaken. The program actually gives me 4 separate error messages. They are, “FireControl.exe – Entry Point Not Found “the procedure entry point ucrtbase.terminate could not be located in the dynamic link library api-ms-win-crt-runtime-|1-1-0.dll.” When I hit the OK button the next message is identical to the first. When I hit the OK button again the next error message is identical to the first. The next error message is, “FireControl.exe LoadLibraryW(C:\Users\user\AppData\Local\FireControl\runtime\bin\jli.dll) failed. System error [127](system error 127(The specified procedure could not be found)). When I click the OK button the error message,”FireControl.exe Child process exited with code 1”. When I click on OK the program stops running. This happens to all three software versions, there seems to be a DLL file missing.
• When I download and install v20.6.2 the files load into C:\ProgramFiles\FireControl\ without issue and the program does run. I installed the USB drivers (Windows 7 machine). The program will connect to the Crossfire (but it seems to be finicky at times) and I can jog the X and Y axis. I don’t know for sure at this point if I can actually load one the of break-in programs or not. This leads to the new unrelated issue.
• I cannot jog the Z axis. When I purchased the table (The regular Crossfire) I purchased all the upgrades with it including the THC. The THC came already assembled with the electronics in a box. When I try to jog the Z axis I can hear the stepper motor run but the leadscrew does not turn. I tried to turn the leadscrew with my fingers and I can turn it a little but it is very stiff. Just to make sure I swapped the Z and X axis cables and I can drive the X axis stepper motor with the Z axis arrow keys but I get the same results using the X axis keys to drive the Z stepper motor, just noise and no movement. I suppose I will have to take the stepper motor off the THC assembly and see if it will run not being attached to the leadscrew unless someone has some other suggestions.
• I also purchased the limit switches too but at this point I cannot use them because I can’t get the 21.1.5 FireControl software to load.

Any leads to these issues would be greatly appreciated.

Regarding the Z-Axis issue, check the coupler between the Z-Axis Lead screw and the motor. Mine came loose and displayed the exact same issues. Tightened it up, and it’s been working fine.

1 Like

Hi Ward,

Hope you had a great weekend!

Give me some time to look over everything you’re reporting so I’m as well-informed as possible when I get back to you. However, I can help but notice that your computer just barely meets to minimum system requirements for FireControl - Windows 7, 4GB of RAM, and a 1.60 GHz processor are all minimum requirements for FireControl, and happen to be the exact specs of your computer.

Due to this, most of your computer’s resources need to be directed to FireControl for it to run properly. Furthermore, if your processor is dropping below 1.60 GHz for whatever reason - a very possible situation - it could be causing FireControl to crash.

Just to confirm: is your Windows 7 installation 32-bit or 64-bit?

As for the Z-axis issue, reach out to us at and we can help with the Z-axis coupler!

1 Like

It will not even start the program before it crashes with the v21.1.5 and 21.1.4 but it runs the 20.6.2 fine. The errors seem to indicate (from what I have been able to locate) that there is a system file missing or corrupt that will not allow the program to load properly in the latest versions. Also the fact that these program are only allowed to install into the Users directory (I tried to install it into the Programs directory but it would not let me. It gave me an error that the installer did not have the proper permissions to install in that directory) might have an effect on this. I have been reading through the forum the past day or so and it seems that the newer versions of the FireControl are have issues with top end machines running Windows 10 and 11 too. Very few seem to have solved their issues or if they did there was no indication the problem was solved other than reverting back to the v20.6.2.

I have another computer that has as 2GHz processor but I need to up date a couple things on it first. I will try that one and see if it helps but even with ,“minimum requirements” the program should be able to start up before it crashes.

The Windows 7 machine is 64 bit

AppData is the default installation destination of FireControl because installing to Program Files while the computer is connected to an internal network causes issues.

After opening the FireControl installer and accepting the End-User License Agreement, you will be prompted to select the installation path:

After clicking the “Change…” button circled in the photo above, a file explorer will open, allowing you to navigate to the desired installation destination:

To install to Program Files, the file path should look similar to the path highlighted in green below (keep in mind that the FireControl folder in Program Files needs to be manually created prior to this process):

As for the theory that a system file is missing or corrupt - try uninstalling FireControl, then deleting the “.FireControl” folder from your C: drive & emptying the recycling bin before reinstalling. The “.FireControl” folder can usually be found via this filepath:

C:\Users\[YOUR USERNAME]\.FireControl

I’m unaware of anyone reporting issues with newer version of FireControl with Windows 10 & 11, could you point me in the right direction to investigate this? The only major issue I’m aware of is the ongoing “Child process ended with error code 1” issue, which is specifically affecting computers with power-efficient AMD processors.

The “minimum requirements” assumes that your computer is running at maximum efficiency. It’s very possible for your processor to be running a bit below 1.60 GHz, even though that’s what it’s rated for.

1 Like

Over the years havr had issues with DLL files while running CF29 toughbooks. Based on already uninstalling and reinstalling Fire Control I would say reinstall windows and then install fire control and see if it works. If works good then run all the uodates and recheck. Sometimes DLL files can be a pain. Good luck!!