Fire control giving no program speed error

i have downloaded the latest post processor from the langmuir site (sheet cam post v1.6) and installed it in to sheet cam. i have made a quick test cut design using inkscape, i then opened it in sheetcam and ran it through post processing using the latest version and if passes and saves. i then share it from the laptop to .my xr computer and try to open it in firecontrol and it gives me a validation error and says no program speed found then says to make sure im using the most up to date post processor. what am i missing or needing to do? couldnt get anyone on xr support line today and now they are closed for the weekend and id like to get cutting

did you create a toolset for the particular gauge of material?

Open the .tap file with Notepad or a similar viewer and copy and paste the first 10 lines or so and the last few lines here.

We will be able to tell if you are doing something wrong by looking at the code.

yes i have one toolset and the feed rate is set to 100 imp

(v1.6-sc)
G90 G94
G17
G20 (Units: Inches)
H0
H0
M5
G0 Z2.0
M30
(PS0)

That the whole file, correct?

You haven’t created a jet cutting operation before post processing.

The good news is that you are using the correct post processor.

I’ll post a video walkthrough of the process when I switch to my laptop.

1 Like

yes thats the whole file im guessing its just simple rectangle with a few circles and star and the word test cut.

This is a loom video that I made of the process to import a file, create a jet cutting operation and post process it. The simulation at the end is not necessary. Loom | Free Screen & Video Recording Software | Loom

1 Like

ok video has no sound is that right? i followed the steps and got it show the paths and ran the post and saved then sent it to the fire control computer and still get the same message

(v1.6-sc)
G90 G94
G17
G20 (Units: Inches)
H0
H0
M5
G0 Z2.0
M30
(PS0)

There are still no motion commands or speed in that file. Can you post a picture of your screen with the toolpaths? Also post a picture of the Tool Settings and the Jet Cutting operation settings screen.

my layer dropdown menu also only has layer 1 as an option

That is all you need. There should only be one layer, unless your drawing has multiple layers. The lines should all turn white when you select the correct layer.

Also, I just noticed that the retract distance is 2". That tells me that you selected the post processor that has been modified to work with Thermal Dynamics plasma cutters. That won’t cause the issue you are having, but it will cause pierce delay issues.

1 Like

i changed the post back to the non edited one

Lets start with turning on the “show toolpaths” and “show true width” buttons, so its easier to see what’s going on.

1 Like

The OP is a new forum user and can not post any more responses for 24hrs, so I’m helping him on another platform.

2 Likes