Fire Control connection lost mid cut

Within the last couple of weeks, I have had several cuts were Fire Control stops mid cut requiring me to re zero and restart program.

Example- I will home my torch and load program…start the cut and randomly the torch will stop moving / Arc still on. Fire Control will be blank like I do not have a program loaded. From here I would have to re launch FC and set zero. Line my torch up with previous cut and restart.

FC is the only software running on my laptop and I do not have any other equipment on that would generate interference. All cable connections are solid and this only happens on a live cut, never on a dry run.

1 Like

sounds like your cutter might b too close to the control box. try moving the cutter as far away from it as possible to see if it helps. also, if on a laptop, use battery power when using the table or add in a 3 prong to 2 prong adapter to the power cord to eliminate the ground prong on it.

1 Like

I never use a power cord on my laptop, so I can rule out the charger interfering. I assume you are referring to the Plasma cutter power source as the “Cutter”?? Currently it is sitting about 10 -12 inches from Plasma Table control box so I will try moving it a little further away (as far as my cables will allow)

I don’t know if this is a fluke, but I did notice that two of the times this happened was when my air compressor turned on. Could a power draw from my compressor possibly cause this. They are not even on the same source line… :roll_eyes:???

i was referring the the actual plasma cutter. i have mine on a welding cart that sits on the opposite side of the table from the control box and still have enough slack in the torch lead for it to operate.

not sure about the power surge from compressor.

That’s what I thought, but did not want to assume without asking. I will try this first before digging in on the compressor thought.

Thanks for your input!

hate to ask…material clamp on the material?

He stated that FC freezes mid cut which is more like interference and not that it loses arc which would be more of the clamp not in the proper place.


I agree…but it never hurts to ask…

Toolboy, lol that is a fair question…as a welder and weld instructor this very issue is probably half of the issues I see with people when they come to me saying their “junky welder” isn’t working right!! So, I appreciate that question!!


I am going to be running some odd jobs tonight, so I am going to move the plasma cutter unit as ground zero for my trouble shoot.

Okay, so I ran several jobs last night after moving my plasma cutter power unit, and had multiple stops …all due to lost programs.

I went through all connections again to verify nothing was loose etc. (all checked good)

I went ahead and uninstalled Fire Control and re Installed latest version from Langmuirs site…which is what I was running anyways. After reinstalling I did several more test cuts which resulted in several program stops again.

I did notice my THC Live voltage readout was off the charts high 115.2 volts - 16.9 volts. I went ahead and performed the THC test which resulted in an error message telling me there was a continuity issue with my IHS and to disconnect from the control box and re test THC. After disconnecting IHS and running the THC test again, the test was acceptable. As soon as I plugged my IHS back into the control box for the table my voltage spiked again.

So, I am not sure of the connection between my issue and the THC issues, but could this be causing my programs to fault out???

I went ahead and sent Langmuirs support group an email, so I will see what their response is and communicate it through this thread,

1 Like

excellent diagnosis and information back…

1 Like

Hopefully this issue can be resolved quickly. I think I am going to disconnect IHS and THC and perform my manual test cuts again to see if my faults still occur. I have several jobs that I am on a tight schedule for and cannot continue to restart programs and realign tool heads with cut paths. So if disconnecting the above items works I will just manually set cut height and run this way until further corrections can be made.

I am hoping it is just a bad IHS cable that I can quickly swap out, but I am never that lucky!!

Take a look at your Z axis IHS contacts… water, buildup, or lodged bunny rabbit could complete that circuit… not sure about the resulting software dive though…

Also Open

controller case a make sure the torch on off chip is seated all the way in socket.

got a spare laptop to swap and test with?

I did clean z axis contacts and did see an improvement in Torch voltage values, however I am still seeing the program issues. I ran 30 straight cuts that resulted in 7 program cut outs. Unfortunatley I do not have a laptop that i can swap to rule that variable out.

Customer support basically told me to do the same thing you have suggested. I have requested additional help, so hopefully Langmuir can figure this out.

PM me your address, I’ve got some extra laptops that are retired from office use. I’ll donate one your way.


In a medical diagnosis I look at every body system, separate symptoms, and choose most important single thing to address first. Root cause analysis.

Because the software crash is the biggest anomaly, I think focus on testing it’s source of failure by ruling out other factors. Do this…

  1. Turn your plasmacutter off, unplug it. Dryrun a file that has been crashing firecontrol. Did it crash?

  2. If it crashed without the plasma on, ruled out plasma EMI as cause. Make sure there are no other high frequency appliances on same circuit.

  3. Swap out computers, do a dry run… no crash? Run the file with plasma on, but do not use auto THC. Set volts to 118, leave rest default. No crash? Repeat cut, attempt to get it to crash with different file…

Let me know when you get that far, hoping for good crispy cuts!


Sounds like at least two things are happening. First, I think @nicaDd is dead on that you have an EMI issue. For that, other than moving the plasma power source farther from the MCB, you should route your power cable, work lead and torch bundle as straight as possible and as far as possible from each other, also separating them from the CNC cable and USB as much as you can. Any loops in these will aggravate the problem. Also, depending on how many ferrite chokes you have on your USB, it might help to add one or two. I found that more than three actually made things worse.

A separate issue is that it seems like you experienced continuity between the normally open (but supposedly electrically isolated) IHS circuit (switch body) and the Z axis or table chassis. That happens when water or grit bridges from the Z axis lead screw or carriage to that brass switch body. The high voltage in DRO is due to the voltage present on the IHS “bleeding” over to the chassis and being read by the THC. This is an unavoidable result of the design, but is easily remedied by blowing compressed air at the switch body and, especially, the plastic bushings (?) that are used to isolate the switch from the mounting point.

By the way, if you are able to cut normally with THC off, but not with it on, there’s also a chance that your power source is reporting incorrect voltage values to the THC.

Good luck and I hope that you get back up and running.


Had the exact same issue and it turned out to be the usb ports on my laptop. Unfortunately couldn’t be repaired for a reasonable cost so instead of buying another 2000 dollar laptop that will run my cad programs I just bought a cheap 350 dollar one to run the table and send the nc files to the new one.

I assumed it was the usb ports right away because my usb mouse would screw up often till it finally quit all together.


So far so good, dry ran several programs with no issues. Performed multiple (20) straight line cuts on scrap using different laptop with no issues. Going to run a program tomorrow live, that has caused problems as of recent. Yesterday I attempted same process with old laptop which still resulted in program freezing…not the case today with different laptop.

I did clean IHC and torch area to get rid of continuity issues with my resting voltage on THC to a semi acceptable level yesterday. It was bouncing between 3 to 5 volts, so I also re routed some of my cables as other members have suggested and I noticed when powering Hypertherm back up resting voltage dropped from 3.3 volts to 1.8 volts and has held steady.

Starting to feel like I may have been having multiple issues feeding the problem.