Everlast 50S Issue

I’ve had my Crossfire table up for a few weeks now and really trying to get everything to work correctly. I have an Everlast 50S contolled with the CNC port. I have read through the forums and although I have seen a lot of problems and cures, I haven’t seen any exactly like mine. I have a brand new IPT60 torch on with all new consumables, good pressure, and dry air. The issue is the ignition of the torch when moving to the next cut, it doesn’t always fire and misses that cut. If I pause and restart it will fire the next cut it gets to. It always fires first cut and the rest are hit or miss. When it misfires the air is not flowing after the ignition try but it thinks it is on as I cannot manually pull the trigger and get anything. Also if I pause it and let it go into postflow, it will fire normally. I initially thought the machine couldn’t react fast enough to triggers from the program, but I ran a program of 9 circles at 15 ipm 5 or more times and it is just random which ones it decides to fire. As others have said with the Everlast, I have checked how tight the electrode is, cap, and holder. The clamp is also good and clean connection. I have checked the g-code and post processor for anything but I believe it is something internal and hoping someone has some ideas.

Are you using sheetcam to post your gcode? If so, try setting the pause after cut setting to 1 or 2 seconds and see if that helps. I’ve got a miller 625ex and have had similar issue - I’ve noticed that it gets worse the higher the amps are turned up - it needs more ‘recovery’ time between cuts due to postflow cooling - I think due to some internal logic that wants the torch to cool - longer with more power. Not sure if that’s what’s going on with yours, but adding some delay in helped in my case.

oh - and welcome to the forums!


What is your pierce delay set at. You may want to try something like .8 seconds or so. There is lag time and short delay time will cause misfires.

Assuming you are in Sheetcam…


And I’ll second what @mechanic416 said re: Pierce Delay. He’s right (as usual :grin:) - I’d start there, and then add pause at end of cut if still having an issue.

1 Like

Thank you both. I am using Fusion. I looked for a way to pause between cuts in fusion and could not see anywhere to do that so I adjusted my lead in and out speed to 15 ipm. I know that is not what it is for but thought it may help or give a clue to the issue. I also used the overrides while running the program and it did not help. The pierce delay I have played with from .5 to 1.5sec. I can see the program delay at that point but no fire. I agree .8 seemed great when the plasma fired. I will never be cutting production so if I have to run the programs slow that will be ok. When I did a pattern of 9 circles, they were 1.5 diameter and I used Firecontrol’s pattern button and spaced them 2" from each other to give some torch off time between circles. That did not help either.

ok…I have the 62i…so let me ask a few things…you may have been asked before…but we will help

is your table the full Pro model with THC?
are you using the CNC port on the back for trigger torch control?
are you using the CNC port on the back for Torch Height Control?
are you running it on 120 or 220 volt power?

make sure your torch cap is snug…not tight…snug
are you using Everlast consumables or knock-off parts

your pierce delay should not be really more that .5 for anything thinner than 1/8"

I appreciate the help. I have the Crossfire table, no height control, and the water table. I have manually set the torch height at both 1/16 and 1/8th. I am triggering the torch through the CNC port on the back of the machine. I run on 220V and have tried genuine and Amazon consumables, 1.0. The torch is brand new also. Bought on Ebay and at least claimed to be the Italian made version. The machine was doing the same thing before the torch change. I changed it out because one of the guys crossthreaded the electrode a few years ago. I had fixed it and it worked great before I put it on the table, but thought it may be the issue along with some burn marks under the swirl ring. I assume from moisture in the air before we had a dryer. I do run the cap snug and the electrode is put in hand tight with out wrenching on it.

Did you solve this problem?
I have the same problem after 5 months of everything running perfect. hours and hours i\on the phone and different forms. they sent me new air solenoids still problems! Same setup as you.

I did but not the way I want. Turns out my machine will not react(stop fire and refire) quick enough to keep up with the programs. It does not always fire if in postflow. I have a brand new torch and the machine itself is a few years old. I emailed Everlast and never got a response. Also I am using Fusion. Anyway, what I did is after each toolpath I write a delay in for 20sec. In Fusion manufacture, right click on setup, new operation, manual nc, dwell, amount of time. Then you can drag it whereever you want. This allows my machine to go through postflow each cut. I also dailed the postflow dial to stop postflow just before the move to the next cut. James5 clued me into this as it looks like Sheetcam has a place to set delay. I am not cutting for production so time is not as important as quality. It also gives me a chance to move tip ups. I did a sign yesterday that had 66 toolpaths and it took 30min so not terrible. 80IPM on 14ga. The real issue I have with this is when the scrap falls into the table, the postflow sometimes blows a lot of water around. If I see a lot of water is blowing up on the torch I will put a bondo paddle edge under the tip until it shuts off, (On the back side of the next move). So yes I am cutting, not how I wanted, but will take it for now and keep trying to find a better way to make it work. I am sure there is a better way to do this, I just don’t have a lot of time on my machine yet. Yesterday was my first complete sucsess. I am open for any others input also.

guys…there seems to a pattern with everlasts, I have the 62i, of the electrode in the torch possibly sticking between cuts…check the spring action in the torch end to make sure it moves freely.
if there is any sticking or resistance…that might be your problem

1 Like

If the electrode plunger is sticking. Remove the electrode blow everything out with air, install an old electrode and with a little pair of pliers work the electrode in and out a few times then plow it out again. then add a little silicon grease and work the plunger in and out a few more times to get the grease

in it and it should free up.

1 Like