Driver watchdog triggered

Hello, just got my machine set up and running. Started to take some test cuts learning feed rates etc. and I keep getting an alarm on Mach 3 that says “driver watchdog triggered” what am I doing wrong. It only does it when it’s cutting. Has not done it yet with the torch off. (Dry run) thanks

Look in general configuration, should be able to disable the watchdog. No idea what it is or actually does though. just uncheck the box if you dont want to use it. I looked it up, Its a warning to alert you your parralel port is underperforming for some reason. I read it on the internet and we all know it has to be true or it couldnt be there right?. I would read up on it.

Yeah I ended up reading on it and figuring that out. Thank you for the reply. I now think I am battling radio frequency issues. The plasma is not turning on and the program is shutting down. The dry run works perfectly but when Mach try’s to start the plasma it’s not working together. I have been reading posts about this. No luck so far

If that’s the problem, then you might find a USB cable with a ferrite choke will help:

But it could be other issues - anything from a HF start torch (won’t work) to issues with installing the appropriate drivers when setting up the system.

Does the F5 key in Mach 3 work to start the torch? (And then again, turn it off once it’s going?) Do you have the ground cable from the plasma cutter clipped to the material itself? What kind of plasma unit are you running?

This morning when I first got it running everything was working together so I know it’s set up correctly. Started thinking I was having ground problems with having the ground on the drain plug. So moved that and thought it helped a little then started having problems with cut speeds and material thickness (just learning) but then started throwing that driver alarm and now I can’t even get the plasma to fire. If I unplug the laptop I can manually get the plasma to start. I have a Aimco Cut 50. One thing I have not done yet is added a 110 plug on the wall for the table. So currently running an extension cord for the electronics which I read could be a issue

I run my laptop and Crossfire control box on an extension (it’s a reel mounted to the ceiling that I pull down and drag across the garage as I need it).

It sounds like you’re getting interference - others have reported that moving their laptop as far as possible from the Crossfire control box or swapping out the USB cable solved that problem.

1 Like


I responded in another thread, but that plasma cutter is a high frequency start unit.

1 Like

Did anyone find a solution for this problem? My Mach3 shows an error when the plasma turns off, or when I’m using the laptop for my router, the error shows up when the spindle shuts off. The error message is: Error on Line: 1 - internal error

Since it has been working properly for a year, I don’t know what could have changed. I have reloaded Mach3 and set Debounce to 2000 but no change. I am using an ESS and have windows 8.1. Any ideas that could help?