Debug help, torch not firing (solved - air too low)

I have the RazorWeld.

My table has been sitting for a couple of weeks. Today I tried to fire and and the torch would not fire - but also no air flowing out the tip (but plenty of pressure at the RazorWeld and all green lights). I double checked the torch on/off control wire at the controller and at the RazorWeld and nothing seemed wrong. The system has not been touched in between. When I hit the “torch on” button on the Langmuire software, I can hear a relay click, but nothing is happening.

Any ideas of where to look next?

Just a shot in the dark would be:

  1. Air pressure is too low to the cutter.

  2. If you hear a click from the enclosure when you try to manually fire the torch, one would think FireControl is working properly. The next step is to pull the torch on/off cable plug out from the enclosure box and short across the two poles. Be careful, because this might fire the torch. If that fires, then you know the plug is faulty. If it does not fire the torch, it could be a broken wire or loose connection at the cutter.

  3. Double check all wires to make sure they are where they should be such as at the VIM box. It has happened that someone accidentally removed a wire and quickly inserted in the wrong spot. Torch and work lead attached to cutter??? Snap a few pictures and post here so we can all be assured that it is hooked up correctly.

  4. Cutter is turned on and lights up appropriately???

1 Like

I agree with all @ChelanJim has said. One thing - hand torch or machine torch on the RazorCut 45? If hand torch, with the cutter one and air present, pulling the trigger should fire the torch. If not, the FireControl enclosure is probably not the issue.

machine torch. air pressure is fine at the gauge on the RazorWeld. I’ll try shorting the the torch on, I’m assuming the problem is there. I’ll post pictures.

Okay, I’m an idiot. When I pulled the plasma torch fully out from where it lives under the plasma table to disconnect the on/off cable, I got a straight on look at the pressure gauge and realized I’d been reading the butt of the gauge, not the pointy end and that it was reading zero. The compressor had tripped and I simply hadn’t used any air for a few days to let me know.

Thanks for the help.


Thank you so much for posting your resolution. No harm done and we have all done similar things.

Your post will help someone down range from here, I am sure.

Too many people are too proud or too insecure to reveal that they are human.