CUT60 THC Interference

I’m starting this thread just to give some general knowledge about troubleshooting the THC (particularly with Primeweld Cut60). I began using the CF Pro back in Dec '20. For the first few weeks, it ran ok without THC. After setting up the THC, it ran flawlessly for the first 2 weeks or so. Then all HELL broke loose. An alarm every. single. run.

I went through all the troubleshooting guides, all the tips and tricks. Had a replacement plasma machine sent. Changed THC chip on board. Replaced VIM box. Switching from PC to laptop. Relocated control panel. Spaced out plasma and PC. All voltages and resistance(s) measured within spec. But still no success.

Conclusion, interference with grounding. I don’t know enough about it to explain details. But running the laptop (without charger plugged in) or PC (with ground wire cut) alleviated the issue for good. I’ll figure out a permanent fix for my setup. Just thought I’d share. I spent months racking my brain on this and endured the frustration. So maybe others won’t have to.

And BIG PROPS to Thomas from Langmuir. He was a huge help.

2 Likes

If running with the laptop unplugged fixed your issue, that’s the same for everyone regardless of their cutter. THC troubleshooting step number one, it’s even in the Langmuir instructions.

I think The cut60 problems referenced are what @Jemejia is experiencing. Where even with the laptop unplugged there is still interference and a raising torch.

2 Likes

@jmccall87 what do you mean by:
“or PC (with ground wire cut)” exactly?
I use a PC in my shop. I have the Cut 60 right now and have been using it with my crossfire OG table for over a year with no interference issues. My Pro will be here by the end of the month… Trying to get all my ducks in a row before it shows up.

Using a PC with a 3 prong plug introduces a AC ground loop problem that only affects the THC’s sensitive measurement.

1 Like

This is why I like the THC3T for my THC controller. It has an ISOLATED, true differential, filtered, THC Voltage input. It is not affected by back end grounding in any way.

So you can correct it by eliminating the ground prong on the PC’s AC cord where it plugs into the wall outlet?
Also is this still an existing problem with the newer Pro units?

I’ll tell you these Lanmuir folks have what it takes. They have a business model akin to Harley Davidson in it’s early days. These guys are here to stay and the technical support from my observations are fantastic.

2 Likes

Just use one of these to eliminate the ground. no cutting involved

3 Likes

noob comment…ready?..“which one do I choose…they all look the same…”

:rofl::rofl::rofl:

2 Likes

Do I put the screw in the tab to hold it in?

OK, so I’m thinking (and that right there can be dangerous) :crazy_face:, the raw voltage signal coming from the plasma cutter to the THC board is quite a noisy bastard. If not tried already, let’s try shielded cable (only one end of the shield connected to ground to avoid ground loops), AND ferrite beads around each end of that cable.
Try grounding that cable shield at the plasma cutter only please. If no success, lets try grounding it at is the control box only.

1 Like

NEGATIVE, then you’ll be grounding it!
It was actually designed to convert an older type 2-prong ungrounded outlet to a 3-prong grounded outlet.

Got ya, you jumped on that one to quick :rofl::rofl::rofl:

My bad… LOL Wrong item listed…

Since removing the PC ground seems to reduce the problem, the problem is more likely ground currents and induced voltages than EMI/ RFI per se.

1 Like

Hmmmmm, if so, maybe a big-ass pi network filter on the CUT60 power line?

A big brother to this one maybe?

Hmmmm, maybe isolate the slats and water table from the rest of the table where you have multiple grounds attached.
As my buddy George is prone to point out, the Work lead is not a ground. It is actually a sense line where beaucoup amps flow and critical voltages are sensed.
Would you tie your welder work lead to your PC ground?

1 Like

The charcoal gray one. The other gray one and the grey ones won’t work.

Are you using the THC3T with a pro table and a cut60?