Crossfire with Everlast 62i won't fire (SOLVED)

I have a new Crossfire table table seems to function okay. I have an Everlast 62i plasma cutter. The roblem is the torch won’t fire using Fire Control. After speaking with Everlast I wired from RAW voltage using the pigtail wires into the Clamp and Torch connections inside, I connected the CNC plug soldered to pins 1 and 2 (torch on/off) input. Everything has been tested for continuity and it looks good. I have been 3 days with tech support at Langmuir (wish they had a phone number listed) and Everlast as well. Done every thing they had told me. I will take the Z axis down to the material air goes on an does not light the machine torch. I am about ready to haul the whole thing to the scrap yard. I’m a new any help getting my torch to fire will be greatly appreciated.

Can you short out the torch fire pins and make the plasma fire? If so could be a bad relay

this means that the Everlast is getting a signal to fire.

Do any error messages pop up?

Any error lights on the Everlast ?

What mode are you using on the everlast?

this was a good move

What is your air pressure set at?

Where is the torch clamped?

If it’s clamped in the lower 3 inches, you could be compressing the moving parts and preventing it from firing.

1 Like

Have jumped pins same response from machine. The relay clicks on. No error messages air connected is at 75 PSI. When I try running the torch test through fire control says voltage is okay, then says height control not working. No matter what torch will not light.

Stop right there, pick up your cell phone and call me.



Thank you George for your help. You solved the problem in minutes. Your the best expert, better than Everlast tech.
Thanks Again


What was the problem and what solved it?

Good Job @mechanic416


Well, what did the plasma wizard tell you to fix? Inquiring minds need to know😫


Maybe Uncle George will tell us?

Well its hard to say what fixed it. I just stated with the basics, check the torch, consumables, air pressure, air settings, plasma cutter settings then jump pins one and two and the pilot arc lit. Run it with the test through the controls and it fired right up.

My guess was the plasma cutter and air settings were off.


Thank you my plasma guru. Buy the way send me 10 50amp tips please. Paypal invoice me please.


Will take care of that for you.

1 Like

Thank you George for what you bring to this forum. I feel like I just witnessed a “special” moment.
(NO. The special moment was not John buying something. That happens a lot.)

You know that you can’t stop doing this…right???

1 Like