Crossfire Pro X axis acting crazy - Motor issue? (Solved, burnt pin)

Hey all, here’s the short story.

X axis acting erratic. If I manually move it via the keyboard, there are times when pressing left arrow will produce a movement to the right, or no movement at all. Other times it is opposite that. On occasion there is what sounds like binding. Then, out of nowhere it will be fine. But recently it’s much worse. Anyone experience this? I’m aiming towards a motor, but I’m not 100% sure. Here’s some more info:

3 year old setup
Widows PC
Always using latest firmware
Table built to spec and everything tight
Restarts sometimes help, but mostly not
All connectors are secure and clean.

Thanks in advance!

Check the connector where the stepper motor cable connects to the control box. Those are well known symptoms of a bad connection. The screws that came on the connectors are too long and they push the connector out when they are tightened all the way.

Pull the connector and look for burnt pins. If it’s not bad, clean and push the connector back on without tightening the screws.


DUUUUDE! That was it. one pin was burnt and I did just what you said, and we are good to go. Nice man, thanks a ton.


You can also use very thin washers on the thumb screws that hold the connectors in just to shorten the screws a fraction…

1 Like

glad to hear it worked for you…I changed the title a bit so people know…