Crossfire Pro not Firing plasma torch, shorting the torch on/off male connector fires the torch (SOLVED)

Recently my dad got a crossfire pro, we’ve successfully made a few cuts on it, but ran into issues today, and have spent the whole day troubleshooting.

In short: When we attempt to manual fire, run a program, or use the THC test program, the torch does not fire, and does not even blow air. If I unplug the torch on/off cable from the electronics enclosure, and short the connector, the torch fires and arcs. When running a program or manual firing, I can hear the relay in the electronics enclosure clicking. The next step I’m thinking of trying is to open the enclosure and visually inspect the connection to the on/off port. We’ve made a few cuts already and they’ve been great! any support or suggestions would be appreciated, thanks in advance.


Crossfire pro with THC
Hypertherm powermax 45 XP with CNC port
Using fusion 360
Torch height control and machine firmware are on the latest version, same with firecontrol.

Check your torch fire relay is seated all the way on electronics board. Make sure the torch fire connector is pushed all the away in barrel of electronics box.

1 Like

when you try to manually fire the torch from firecontrol do you hear the relay click? You should and it’s a common problem for the relay to become unseated.

I do hear the relay click, i reseated it, and we’re cutting, but it didn’t really feel loose before. Leaves me a bit uneasy that that was actually the problem.

Reseated the relay and the cable, we’re cutting now, just hope it keeps cutting!


I will mark this as solved for you…

When anything errors or does not work I will go through all my checklist hung on the wall…

first thing is to check all connections…
believe it or not I get that problem of the on/off jack loosing connection all the time…

How do you fix this?

fix what. ???.