Crossfire Pro Doesn't always trigger the torch

Been running this crossfire pro with a hypertherm 45 since last June. I wouldn’t consider it heavy use at all. A few months ago turned it on to cut and had some troubles getting the torch to fire. Did the suggested pierce height delay, etc. Shut it all down and came back an hour later and it worked. I thought it was a ground issue so I made certain the control box was isolated from the machine frame, connection on ground lead good on both the machine and table. Ran a few little jobs since then. No problem. Today, doesn’t fire. I hear the relay clicking when I try to fire it manually. I have a machine torch. I’ll test the Plasma with a handheld now just to make sure. Maybe there is another ground connection that I am missing. Thanks.

Send a picture of your torch mounted in the holder.

Make sure that the bottom torch clamp is not too tight. Take off the cap and see if the electrode can be pushed up and snap back down. That is how the torch ignites.


Make sure the torch on/off cable is fully pushed into the connector. Also, make sure it’s not broken. I stepped on mine and broke it at the connector.


I saw another post about the ground in that comes from the THC and connects to the Z axis being a potential problem. While I had that wire loosened up I saw BigDaddy’s suggestion. I loosened the lower screws a little. Snug. Tightened up the ground on the Z axis and it works. Maybe one of the two actions was the solution. Maybe other gremlins are at work! If I see this problem again I’ll go after that ground wire first. It really is in a horrible place to get to. If I run into this again I’ll look first at the wire connection on the Z. If have to take the Z axis off I’ll make a little plate that gives me better access to that ground connection.

That torch on/off cabling is a bit if a hassle. It needs to be twice as long so I can tuck it away. Keeps things too close to the table and the table is a pretty messy place to have things. I’ll have to look into solutions for that next.


That ground wire is not a ground wire but a connection to the IHS system. It is necessary for the THC operation. It does not have anything to do with firing the torch.

so with the plasma off you hear and Firecontrol on…when you “test fire torch” in FIrecontrol…do you hear a “clcik” from the langmir control box?
then most likely as @ds690 good old David said the 5mm round jack is not making proper contact…with the power off you can ever so slightly bend the center pin a bit to help make contact and hold the pluig in place…

then there could be a chance that the little circuit board inside the Langmuir control box is loose…open the control box…there is a small circuit board with a little black relay box on it…pull it pit…then push it all the way back in…
try the fire torch to see if the relay works…
if you hear a click…then the program and the box are working properly…

Neither of the wires attached to the Z axis are ground wires. Those two wires are the IHS circuit wires. When the IHS switch is closed, it connects those two wires to complete the circuit.

1 Like

Maybe it was as simple as loosening the bolts around the base of the torch.

That circuit is closed through the metal that the screw is fastened through?

Yes. It is a simple open/closed switch that tells Firecontrol when the torch meets the media to be cut, the when it comes off the media .


There are two contacts in the Z axis and those wires are each attached to one of them. One is attached to the carriage that the torch is attached to. The other is attached to the lead nut. They are normally closed, completing the circuit. When the torch touches the metal, the.lead screw nut keeps going down until the contacts open and break the circuit.

If you get the IHS failure message, it means those contacts are open or one of the wires is not connected.

1 Like

Thanks. Yes, that switch back there now makes sense. That makes sense that dry firing in fire control is unaffected by what that switch is doing.


What is this? Looks like maybe a PEX cinch clamp? Whatever it is it is clamped on the torch head. As @Bigdaddy2166 said there are moving parts in there. You shouldn’t have anything clamped around that portion of the torch.

Here is the @mechanic416 torch mounting figure.

1 Like

A Hypertherm Ohmic Retainer Cap.



Thanks! I did look up pics of the Hypertherm torch before I posted. Didn’t see that on any of them so I figured I would ask. :+1:

TinMan, your plasma library must look like the library of congress here in the states. You don’t have anything top secret do you?


Not top secret but I seem to remember him having a copy of the US FTC documentation on what is and is not considered Made in the USA. :stuck_out_tongue_winking_eye::joy:


I started a post about bathrooms and garages… then thought better of it. :wink: :rofl: :joy: