Crossfire fires torch non stop

I got my xfire last week and it’s been cutting perfect every day until today. My razorweld 45 cuts non stop whenever it’s plugged into the crossfire. It works fine when unplugged from the crossfire. It will fire with the crossfire unplugged from power and unplugged from the laptop. As soon as I put that cord in it lights up. I’m thinking it might be a bad board? I was order #9720

Just wanted to add, before someone recommends it. The torch is in 2t mode when doing this. I’ve tried cycling the modes just to see and it still does this. Functions 100% as a handheld unit unplugged from the machine.

You can check the continuity of the cable with a multimeter and make sure that you don’t have a shorted out cable, but with it firing as soon as it is plugged into the board even with no power then I would think that you may have a relay or something stuck as you suspected?

Good luck

I’ve left the shop for the night, but I did some checking with a meter. I didn’t check the cable with it unplugged from either end. But I did take the cover off the brain and unplugged the two connectors right before the plug in for the cable. They showed continuity. I’m assuming connection means torch fires and no connection is off.

That is what I would think but I have never checked it since I haven’t had a problem similar to yours. The easy was to check the cable is to just plug it into the Razorweld only and see if it fires, if not then I believe the cable would be good. If it only fires when the other end is plugged into the control box then I think that is in the control as you mentioned.

Yea, I tried with the cable plugged into the cutter and unplugged from the crossfire and it did not fire.

Might be worth adding that this problem started when I was cutting a piece. It didn’t fire on the last bolt hole (which is the first malfunction I’ve had), then it cut the perimeter of the piece and then would not shut off.

I’m sure that Langmuir will help with your troubleshooting and figure it out.

have a great evening.

I sent this problem to langmuir on their support page this morning. 14 minutes later I got a reply that it was most likely a bad relay and they’re sending one out ASAP.

Now THAT is customer service.

2 Likes

AND… It worked for a week and now it’s doing the same thing. Just getting ready to take some orders and now there’s no way I’ll get this thing running in time to get anything done and finished before Xmas. Emailed langmuir, so we’ll see what happens.

Why do I keep killing these relays? Maybe it’s the razorweld?