Bypassing Torch Fire Relay - Solved

Hi everyone. Torch does not fire and the relay does not click. There is a red LED lit under the Relay and it does not click when I try to fire the torch. Also if I jump the pins on that board that go to the torch the torch fires. Relay is set firmly in place.

My question is do you think that since it fires when I jump the pins on the relay board that is indicating that the relay is bad?

Crossfire with extension table
THC kit - not installed
Hypertherm Powermax 30 Air - connected to the violet and orange wires

Sorry I should have also added that I am using a Laptop that is not on the table and there is nothing attached to the table. It is just odd to me that the torch fires when I jump the pins so I feel like for sure that is showing the wiring is ok and must be before that which I think is the relay

Nothing unusual about the torch firing when you jump the pins. That’s all the relay does. It closes contacts inside to jump those pins.

Has the torch ever fired from Firecontrol?

If the relay doesn’t click when you hit the manual Torch fire button in Firecontrol, the relay is probably bad or not seated correctly on the board.


Thank you for your response. No it has never fired as I am just setting it up. Since I can jump it and it fires it seems like I am verifying that the wiring is ok to the torch. But there is definitely not a click when I try to manually fire from fire control

Sounds like a bad relay but it could also be the board. If you take the relay out and test the coil that would help you run it down.

Is the power on to the electronics enclosure?

Can you move the Torch from Firecontrol? The USB will show a connection without the electronics enclosure powered on, but the stepper motors won’t move and the relay won’t work.


Thank you again. Yes fire control sees it and it moves into position to start but it never fires. Same with manual fire or straight line from fire control

Just a quick update. Worked with support, by the way super impressed with that, and they are sending a new torch fire relay. Once I get it I will let you know how it turns out. Thanks again


Well received the new relay today and unfortunately the exact same behavior and the torch still will not fire (only if i jump the pins). I’m kinda bummed but I submitted a reply to my service ticket and I know we’ll get it working at some point. I guess I’m now looking at maybe the system board because I doubt I would have 2 bad relays.

1 Like

A little progress. On the new relay if I tap the relay a couple of time the torch will fire and I hear clicks. But I have to tap it each time to get it to fire again. I know it needs to be seated well and I can’t press on it any harder. However, the black female pin connectors on the back of the relay that mate it to the circuit board are so loose that they literally slide right off with no pressure. So that could be a problem but the tapping I wonder if the relay is getting stuck closed!

If it was stuck closed, it would be firing all the time. I think the issue is probably the connection to the board.

1 Like

Good point. I Should have said stuck open. Yeah I think you are right. Support is sending me a new board. They have been really good about this so I’m thankful for that. As a side note, that nobody will really care about, I grew up just east of the Conroe location so will likely stop by next time I go home. Anyway, for anyone reading I will post updates as they happen


Also ds690 thank you for always helping me out. I greatly appreciate it and hope you have a great night


Solved!!! Installed the new fire control board that support sent me and everything is working perfectly!!! Thank you everyone!!! Seriously appreciated


Mine seems to be stuck closed an fires anytime I turn the plasma cutter on, or unhook anything, the realy is always triggered, and doesnt do anything if the computer is hooked to the controller or if I engage and turn on the torch in the computer, because the relay just stays on. Email into support, no reply yet. Crossfire XL with Z axis and THC, HynadeCut60DN

You can test to see if it is the relay by unplugging the torch on/off wire from the electronics enclosure. If it fires with the wire unplugged from the torch on/off port, the problem is in the wire or the plasma cutter.

Just received the relay and board for a crossfire pro. I’ve been using this machine for about a year now with no problems, until recently. They sent a board and a relay.
At the bottom of the board the new board is missing a red pice about 2" long. Don’t know what it is. Do I remove the other piece from the old board and reuse it?

That is your THC board and it is a add-on/upgrade to the main. You will have to use the one from your old board

1 Like

Ok Thanks for the quick response!