Binding when changing directions Y axis - Solved

So after what felt like forever I finally received my final box and started getting everything together.

Super impressed with how the hardware was packaged and labeled. Really made things a breeze. The only real problem I ran into was preloading the bearings which is now I assume the cause of my grief.

When I initially adjusted the set screws per the directions everything felt awfully tight when moving by hand along the Y axis. In fact it was tight enough that it was marking the tubes where the bearings were rolling (I don’t know if that’s normal) so I adjusted it a few times and was happier with the travel even though I had nothing to compare it to.

Got everything together and went to jog it and everything moved but would jam up when moving along the Y. Finally figured out it is binding when changing directions. I can see the when I reverse directions the two sides aren’t moving the same and will bind until I stop jogging and start again. On the second jog in either direction it will move just fine.

Did I go too far in loosening the Bearings allowing slop which is causing the binding? Or do I still have it too tight causing one side to drag and then bind? Not sure why I’m having such a hard time. Also, it appears that for each pair of rollers only one of each pair Is making contact. Is there a procedure now that everything is together to adjust this?

Thanks all!

keep in mind not all bearings are touching nor need to be.
go back to loosen them all up and then adjust so the first one touches…then tighten up the set… just barely touch…
it should roll pretty freely.
there are alot of topics on this adjustment…it comes with trial and error…


Also check the lead screw motor coupler on the side that is ‘lagging’. If it is slipping then that side isn’t being driven. Given this happens in direction changes that would be my guess.

1 Like

good call Greg…I had that happen also…the motor spins and does not turn the screw…I have gotten into the habbit of doing some test runs and watching the motors before I start cutting

That’s a good thought! I went out and checked it though and it isn’t spinning in the coupler.

As I’m looking at the table the left hand side seems to start moving a split second before the right hand side does which is causing it to bind up.

I went and followed a few of the bearing adjustment procedures on other posts and believe I have that much better than it was.

Any ideas on what would cause the right side to move a split second slower than the left? It only seems to be a problem when changing directions. As long as I stop and start in the same direction I’m pretty good.

did you align both Y axis carraiges? there is a step where after you install the motors, you jog it to the extreme of one side or the other until both Y axis carraiges hit the stansion plates so they’ll be parallel to each other.

1 Like

I did, and I just went ahead and jogged it to the lower right corner and loosened and retightened them. Both sides are making contact with the stansion plates, though not every bearing is touching them there is at least one on both carriages touching.

Here’s a couple videos. It’s kind of difficult to capture whats going on, but they definitely aren’t moving at the same time/speed when changing direction. Not sure if that’s because of drag, or something I have misaligned, or what, but any other suggestions on what to check would be great!

does it jog to either extreme? if not then maybe you have the wrong axis motor/bearing mounts installed? the Y axis mounts are a hair longer than the x axis.

another thing you can try is loosen the lead nuts on both ends a little, then re-align and see if that helps.

BTW, love the Breakin reference on the video title… :laughing:

1 Like

I would suggest taking off those two leadscrews and make sure the gantry slides acceptably by hand, adjusting the bearing pressures against the tubes as necessary.


I wondered if anyone would catch that :rofl:

1 Like

I slowed the 2nd video down to 25% in the youtube player and you can see the problem.

  • check the screw in the end bearing that screws into the lead screw. Make sure it is tight, wrap a rag around the lead screw and hold with a tool if needed to tighten the screw.
  • use a marker or paint pen to mark the coupler and the shafts, to verify they are not slipping.
  • check your square tube/rails for scratches. I had some on mine that didn’t seem like they would be trouble but it would stop the y axis dead, filing the scratches/burrs took care of the problem. Unlikely in your case as it doesn’t seem position dependant, but you might want to check.
  • as others have said, remove both lead screws and verify that it moves freely. In this video the first part shows mine with the lead screws removed, I’m pushing lightly with one hand. It moves fairly effortlessly. The binding later in the video was caused by the scratches.

Took the screw out to push it by hand. I had adjusted it a few times after putting it all together and it definitely moves much better than when I originally put it all together.

The only concern I have is that when I slide it all the way to the extremes the blocks don’t touch on one side like it’s out of square, but when I hold a square up to the corners is looks good. I’m going to find a longer square and remeasure the rails to check that they are parallel.

do you have the same gap if you try to push it to the extreme to the opposite stansions?

Alright, so I did have the sameish gap on both sides. I measured to make sure the rails are parallel. They are right at 1/32" apart at the extremes, so I believe everything is good there.

So I loosened the bolts that hold the gantry tube onto the carriages and slid it so both sides were touching the stanchions and bolted it back up.

I hooked up just the Y2 motor and ran it and everything was smooth as butter. Success!! Or so I thought. I hooked up the Y1 and it was back to binding. I unhooked the Y1 motor from the lead screw and it would run like that with zero issues at all. As soon as I hooked up the motor to the screw and tried to jog I have the same problem.

This is driving me nuts!

swap the lead screws and do the same test again… see if it follows the lead screw.

Well I’m only half stupid, haha. I’m confident that my problem was first the bearing being WWAAYY too tight and then the gantry tube on the carriages not being properly aligned.

Everything would have been peachy, but at some point during the realigning the gantry tube I managed to knock the Y1 motor connection loose at the enclosure. This is why it would not run right with that motor hooked up, it didn’t have any juice!

I noticed while jogging with the motor disconnected from the lead screw that it was not turning. Hooked it up and I think it would turn from the other side moving it making it APPEAR that it was working, but no such luck. Reseated the connector and VOILA! I think we’re in bidness.

Thanks all for all your help and hopefully this helps someone else out down the line!

1 Like

The devil resides in the little details :grinning:
Great, you got it sorted!