Arc blows out after a few seconds SOLVED

what would be reasons for my torch to just stop firing after a few seconds of the cut it fires then stops nothing has changed new consumables yes ground clamp was on voltage is reading

the torch works when I use it by hand

Pretty new to this but

relay clicks

Voltage:115v when cutting

Psi:75psi when cutting

Ground clap on :white_check_mark:

I understand your ground clamp is on but but does it have good continuity? sometimes the work lead connection at the machine loosens as well. Are you hitting your duty cycle of your machine. How long does it fire before it quits. What kind of plasma do you have? Welcome to the forum.

1 Like

Razorweld 45 and soon as it starts it stay on for maybe 5 seconds and the arc goes out I have checked the ground at the machine as well

My guess is the machine is not getting feedback that an arc is started…Usually that is due to lack of continuity to the work lead. My only other guess is a sticky plunger or improper air. its staying in blowback mode instead of transitioning to cut mode. You might check the plunger and make sure that it moves freely. Other than that I have no further suggestions but others will be along shortly and will no doubt get you fixed up.

thank you! I know the air is good

Welcome aboard,

The Razorweld need 100 to 120 psi to the plasma cutter and 70/75 psi on the front gauge when cutting.

Pilot arc only lasts for 3 to 5 seconds. If the plasma cutter does not read a positive from the metal being cut (wear the work clamp should be) it will shut the arc off.


It has 75 at the front, yesterday I cut out a pretty big sign and today it wont cut at all! same material

Did you try changing the consumables?

Yes I did, after the first attempt and when I seen it didn’t cut I changed them out same thing happened

If you are getting a pilot arc, the work clamp is on a clean spot of the metal and the torch is .060" to the metal it should cut. If it does not then there is most likely something wrong with the plasma cutter.


okay well thank you everything is correct so ill try some more stuff tomorrow and see if i come up with anything maybe run some of my old g code and see if anything changes

Its not a program problem. Its a plasma cutter problem not transferring the arc.


So what you think I need a new plasma cutter?

I would like you to do a few tests. If they do not work, then yes the plasma cutter is bad.

If you want to call me tomorrow I will walk you through the tests to see what may be wrong.

George’s Plasma Cutter Shop

1 Like

Okay thank you I will do

Torch clamps to snug can cause firing issues but it usually just spits around. It is worth checking.

I will say when I loosened it, it got better because I had that thing super tight. But still no good

1 Like

Was it so tight that swirl ring may have been damaged. That would take a lot. Does plunger move freely?

I’ll check tomorrow thank you

1 Like

George will help you out he does know his stuff. Just thought of some common problems.

1 Like