X-Axis Suddenly dead

Me: Crossfire table, Razorcut 45, Firecontrol (latest version)

problem: I did two jobs this morning with no issues. Very Happy. I went back to the shop this afternoon and the next job was a disaster. I quickly noticed the X-Axis wasnt moving or responding to jog commands. I checked the adjustments for the boom and it all seemed fine. I removed the lead screw and the carriage moves freely with no apparent impediments. I reassembled everything, cancelled the job, restarted FireControl and tried to jog the axis. The stepper motor made a noise and seemed to turn the screw then nothing. For kicks, I tried a dry run on my program and only the Y-axis was responding. Finally, I removed the stepper motor and tried it without being connected to the lead screw. Nothing happened.

NOTE: I was using my old HF Lotos 5000, but bought the Razorweld and have done three jobs since that turned out great. Not sure if I damaged anything before switching machines.

Any ideas or guidance would be appreciated.


Are the X-axis couplers tight? If they are, try switching the X & Y cables to see if the problem persists or if it changes to the Y-axis.

If it does persist it points to a motor or control board issue. If it transfers to the Y-axis, then it’s likely the cable.

I wasn’t sure if they were interchangeable like that. I’ll try it. Thanks. (Won’t be until the morning though)