X-Axis motor locking up?

Hi, I have had my crossfire pro running for a few days now. One thing that I’ve noticed keeps happening is that my X-axis motor will either freeze up randomly or really struggle to move. Initially I thought that I was having a binding problem with the lead screw or the carriage but I no longer think this… When troubleshooting I would try to move the carriage along the x-axis and with a little assistance from my hand turning the lead screw it would move… but the weird part is it would move very slowly with a lot of effort and then the positive x and negative x axis would switch directions. So even though I would tell it to go to the right it would go to the left ect. It also randomly switch so at some points it would go to the right say 5 inches then while still pushing the right arrow key it would start going to the left? Its almost like the motor was fighting itself to turn both directions at once. I was stumped. So I turned off the electronics enclosure, unplugged the x-axis stepper motor cable and restarted fire control… this fixed the problem and the x-axis ran completely smooth with no binding issues. I thought maybe the wire or something was loose and this fixed my problem. I then ran the machine again yesterday and it ran fine for the first hour or so and then the issue started again, I repeated the process of unplugging and replugging, restarted fire control and it worked fine again.

I have very little knowledge when it comes to electronics or interference issues ect. if anyone has any ideas I would appreciate the input, thanks!

I have a Razorcut45 plasma cutter from Langmuir.

1 Like

some steps to help…

  • pull out your lead screw and make sure your gantry is smooth running by hand in every direction.

  • ensure your lead screws and secure to the motor drive shaft…there have been issues with loose couplers.

  • plug the y motors in and try moving only the y axis…

  • then do the x motor only…

  • then the z motor

  • just make sure without any torch on or nearby the teble can move easily.

  • then make sure all your electronics are properly islolated…put ferrite chokes on all cables…

  • are you using a laptop or a desktop PC?

  • check your grounding …several threads on that for PC and for the USB to check

  • keep the plasma out of it and off for now…eliminate that for now.

hey, did this ever get resolve? I am having the same issue. Not exactly sure whats going on with the x axis motor, but in the middle of cutting it went right instead of left and threw the whole origing point off. i had to retrace the path in dry run mode, then reset the origin and recut. Sometimes itll lock up and throw off the positioning, or it will go the opposite direction. A video shows me just jogging the motor and it showing the symptoms.


1 Like

make a line with a sharpie across the motor shaft & coupler and try to jog it again then check the mark to see it stayed in line or is offline. that’ll tell you if the coupler is slipping and which end.

1 Like

the coupler is tight, and it’s not slipping. It seems to be an electrical issue maybe. Some kinf of noise possibly? In the video, I only click for the machine to jog in the +X direction, but itll go -X, +X, or just jam.

Unfortunately I haven’t had a lot of time to mess with it. I did do some more cuts and didn’t have any issues while jogging or during cutting but did had a binding issue while approaching the starting point before cutting (multiple times) which I believe was related. The fact that it doesn’t happen every time makes me think that it is most likely a noise issue, in my case at least, but I haven’t figured out how to remedy it. Please let me know if you find any solutions, I plan on working on it this upcoming weekend.

yeah, so my situation is that after normal installation I was having a binding issue where it wouldnt be able to travel smoothly only on the right side of the table toward the edge where the lead screw gets close to the shaft bearing. I found out that it’s because the lead screw was tightened in the middle of the shaft, but the shaft seems bent because you can see it wobble very slightly. so when the lead screw approached the bearing, theres too much tension because the shaft want to woblle a little, but the lead screw is holding it in place, and that force starts to overcome the motor’s force as it gets tighter toward the bearing. I dont know why iy would be bent, it’s a very thick rod and I;ve only had the machine for a few months.

To fix the issue I loosened the lead screw so that it frees the wobble and theres not a lot of restrictive force, but now the lead screw moves in a circular motion on the Y plane with the shaft and thats when I started getting the issues you mentioned only in the middle to top part of the table. Is your lead screw tight or loose?

Usually a cut job took me about 5 mins for these repetetive parts, but now its 15 -20 mins and Im just floating on the pause program button hoping I can react quickly enough before the cut becomes too noticeable, I am worried it will travel in the wrong direction again and cost me another sheet which I’ve already had to scrap 3 due to the x axis motor.

My lead screw is tight. When I first assembled the table I also noticed that the lead screw was not very straight. Once I tightened everything down it ended up working out but I’m sure its putting unnecessary strain on the X-axis motor since its not perfectly straight. The fact that the carriage will switch directions on its own really has my leaning toward it not being a physical problem with the lead screw though, even though I’m sure that’s not helping.

When this first started happening I could feel the motor aggressively fighting itself trying to turn. Once I unplugged the motor and restarted FireControl I went over the same area of the lead screw that was binding before and it glided over it like nothing happened… has to be something else other than just a faulty lead screw.

1 Like

are you up to date on the FC 20.6.2?
then make sure all your cables are not tangled up and you have some chokes on the cables.
do you have the newer table with the mod done tro the circuit board to reduce the Em field issue?

1 Like

I received my table about a month and a half ago so I am not sure to be honest. Should I put a choke on every cable or just specific ones? I have one on that cable going from the electronics enclosure to my laptop but I don’t think I have one on any of the others. I may need to order more I don’t think Langmuir sent me more than the one.

My wires could also definitely use some detangeling…

I have them on all wires…what the heck why not…no problems here except me…

Would you happen to remember where you got your chokes from? I know theyre easily buyable on amazon ect just wanna make sure I get ones that work well with the system. Thanks!

amazon…bought a basic selection to have on hand to fit any wire

I haven’t used my machine for a bit but this week cut a couple of simple brackets etc. (I had previously been tracking down a problem with the THC). I was cutting a larger much more complicated piece it was working perfect and the X-axis locked up. I tried putting some lubrication on the lead nut with no success. I loosened the two screws holding the lead nut, again no success. I can sometimes get it to move a bit but also sometimes the direction of travel was reversed. I removed the lead nut and lead screw. The lead screw seems to have some deviation but it has worked so far so don’t know if is a factor. the motor works with nothing attached I put it all together trying at various points in the process it stopped working reliably when all put back together.

If the direction was reversed from the expected motion, that points to the DB9 connector that connects the motor to the control box. Pull the connector and look for burnt pins. If they aren’t burnt too badly, you can clean them and put it back together without tightening the screws that hold the connectors on. Those screws have been known to be too long and actually push the connector out when they are tightened al the way. This causes arcing between the pins and unexpected reversed motion or weak motor output.

1 Like

ds690, THANKS not sure if the two problems are related or just a side effect of me messing around. I will check the connectors more closely. I did look at them and they looked good. But I was just looking for bent pins. Or if related to excessive attempts to jog. Also the tip on the over tightening I’ll check that.

I ran through the assembly procedure for the X-Axis and I cleaned the 9 pin connector. Still wants to jam up but consistently when it does get moving wants to go the wrong direction or only one direction regardless of the arrow key pressed.
Any further suggestions to narrow down the issue? Stepper motor? electronics?

I contacted tech support. They agreed with your suspicions about a connection issue: makes sense. I may still have a mechanical issue but one issue at a time. Today or over the weekend I’ll replace both the male and female 9 pin connectors and see if that solves the problem. Also the connector screws where too long so i shortened them (good tip)


Problem solved! Replaced motor fixed it seems to be working great! Was not rhe connector or the loose conector took out the motor as i replaced both the 9 pin and it did not help.

Both tech support and USPS were quick. The intermediary shipper not so much. Wondering if i should invest in a few more replacement parts on spec?

1 Like

3 years and the only thing I have had issues with is the torch fire relay board…other than that…keep it clean and oiled and it will run like a beast for a long time

1 Like