Torch not firing except air, RW45

Hey all,

Probably gonna be a basic fix but trying to do the first cut on my table. Got an RW45 from Langmuir.

If I do Manual Torch fire it only starts shooting air and that’s it. I have the ground clamp attached to the metal, also tried it attached to the slats.

In THC the live voltage shows 0V and if I go to cut it fails for not detecting voltage. I have the port from plasma hooked to div input, then div output to the table. Also none of the THC things light (active, ok, up, or down)

If I swap the ports on the RW45 I see 261V in the live voltage feed, try to fire and I get no air and no fire.

Any ideas? I tried searching but any similar topic was just a dead end.

knew it would be something dumb, i am running a PTM60 machine torch (from george) and had the 60A consumables in it that came with it, had my machine at 30A. Guess for whatever reason it just didnt like that and the arc wouldnt start. Everything works now after swapping to the 40A consumables

1 Like