Torch Fires for Split Second

Set up my CrossFire today with the Razorcut 45. Everything seems to be working except the torch will not fire. It will follow the entire path with air and only fire for a split second at the start of every path, only enough to leave a small dimple in the metal. Does the same thing when hand cutting as well.

Is the work clamp attached to the material (not the water table) and do you have the trigger switch on the power unit set to 2T?

I have that problem a lot. I had a bad torch fire cable. But I also think the RW45 is kind of a cranky machine. A few thousandths too high and it won’t maintain an arc. I have a Miller 625 extreme and it will maintain an arc cutting expanded mesh. I’m certain the 45 won’t do that. So I say that to say just start going through the troubleshooting process. Air flow can do that. Poor work clamp connection…bad consumables. Etc.

And I think mach3 runs glitchy. Sometimes a reboot solves the issue for me.

Also on the 45 make sure the machine isn’t set to air test.

If you hit F5 with the torch lifted off the plate, does it maintain a pilot arc for a few seconds?

I’ve tried both grounding the water table and the workpiece and the using the hand torch manually with same result. And both 2T and 4T.

Negative. Only a split second of arc.

The button to the right of the 2t/4t switch…is the indicator light in the upper or lower position? It should be in the lower.

First thing I recommend is to double check that you have installed the correct consumables correctly. Then experiment with the retaining cap tightness. If nothing works you’ll need to contact Razorweld for help.

1 Like

I’ve tried both, no dice.

Is there a good diagram for this? Also, anyone have a link to extra consumables?

Sounds like you need to get in touch with razorweld

So looking at other cutters, does the electrode for the RW Cut x45 screw into place?

No the electrode does not screw in on the X45 torch.

The electrode screws in on the IPT torch.