THC Raising towards end of cut


I’ve been having issues with my Crossfire Pro fitted with THC.

Towards the end of cuts the THC is raising to about 1" above the work surface.

Im running a hypertherm 45xp with machine torch and CPC cable.

Things i’ve tried:

  • uncoiling all cable
  • Making sure cables arnt running over each other
  • No continuity between bed and control module
  • Work is earthed to clean part of material
  • Running ver 1.10 of THC Software
  • Downloaded latest machine profile for fusion 360
  • Used multipul differnt cut files
  • Used generated strait cut in fire control v21.1.5
  • Cleaned contacts on THC
  • Installed new consumables
  • Resting THC Voltage 0v

Cut starts out great but towards the end of the cut the torch gradually over a few inches raises to about 1" above the work surface and doesnt come back down, even on non warped material, the THC is commanding down but it doesnt come down, Live voltage is around 111v but goes way up when torch raises too high.

My machine is a few years old and I remember reading somwhere there was an upgrade to the module, how to I tell if mine has the upgrade?

Welcome to The Forum.

I would set your inches per minute to 50 in fire control and use the page up and page down keys to raise lower the z-axis manually to see if it is running smoothly with no chatter or sticking.

I would download the post processor off langmuir site and use that instead for the time being.

Which windows are you running? I’ve seen some people running Windows 10 sticking with 20.6.

Are you running a laptop? If so make sure it’s not plugged in during the cut.
If it is plugged in make sure you use a two prong adapter so it eliminates the ground.

I would make sure your THC chip is installed snugly in the board.

My best guess right now is that the z-axis is binding up somehow I would move it up and down with the page up and page down keys at 10 ipm 50ipm 100ipm( carefully you don’t get too Rammie and a hundred inches per minute there’s not a lot of travel.) Make sure it’s moving freely and smoothly.


Thanks, I appreciate the response, the Z axis is free (Table is brand new, like 3 cuts old).

I have found however that there is continuity between the table and control box only when the motors are plugged into the box and its powered on. Even with box removed from the table, and it doesnt matter which motor is plugged in, all of them cause continuity to the table.

Any ideas on how to fix this?

So once you have electronics enclosure detached from the table with a motor plugged in and you have continuity, what happens if unplug your IHS and or THC connection circuit, do you still have continuity?
Trying to narrow down where your return path is.

1 Like

The other thing you might want to try is to just adjust the position of the torch in the mount.

Your description really seems like z axis mechanically hanging up.

When running the torch with the THC ON do you ever see it making a downwards movement for correction?

Being your running a hypertherm interference seems really unlikely.

Are you using nominal voltage from hypertherms cut charts or smart voltage to control the THC?

1 Like

Tried with smart voltage both on and off, yes the resistance is there with only a motor and power plugged in, doesnt matter which motor however its only 20K ohms so mabey i’m chasing ghosts.

Im doing all of my testing with a decently warped piece of material and the thc works perfectly fine moving up and back down as it should until the final 4 or so inches of the cut where it climbs to about 2 inches above the work piece.

A video of whats happening, let me know if youd like any more detail.

Does all wires and torch have plenty slack?

It looks like the Z-carriage is sticking on the way up. If it’s commanding down and the axis is not moving down, I would look for a mechanical problem in the Z axis. It might be binding or the motor coupler is slipping or a combination of the two.

It is not raising on its own at the end of the cut. It is raising for the warp in the material and it is not able to move back down, because something is preventing that movement.


Starting at about 51 seconds

Why is the IHS led blinking 12 times after the initial height sense during the cut?

I would unplug the initial height sense hook your ohm meter to it. (This would mainly be so you can keep it in the same video frame when you do the up and down test of the z-axis)

Then manually run the torch up and down on the z-axis using the page up page down keys making sure you touch off on the plate and engage and disengage the IHS as it would be during the cut take note of it engaging and disengaging with the ohm meter(you could use the LED indicator in fire control instead of ohm meteras well)

10 inches per minute
50 inches per minute
and 100 inches per minute( careful with 100 inches per minute it’s pretty fast for the z-axis)

Shoot a video of that.

1 Like

I am having an issue. I had/have a razor45 on a cutpro and it always worked flawlessly but I started cutting 3/4" steel so I changed to an everlast 102i and now it seems the tip will randomly ramp upward as high as possible in Z and then pops the circuit breaker for the plasma cutter. It’s so bizzare since I never had this issue with the razor45. I pulled the THC interface box out of the Razor45 which was connected RAW and installed in the Everlast RAW (saw too many complaints about using their CNC connector).
My computer is a HP all-in-one which has an external power brick and two prong plug.

Not sure if it is similar to your problem.

If this THC interface box is the VIM(black plastic box), how did you have the Everlast voltage hooked up before you ripped it out if the Razorweld?

All plasma cutter voltage has to go through that box, whether it is divided or raw.

Sorry if I explained wrong. When I bought the table I had a razor45. using RAW voltage the banana plugs went to the VIM (mounted outside the razor45) and then to the controller. when I got the Everlast I bought a set of bananas and attached to the torch + and - inside and routed the bananas through the vents. So now both the razor and everlast have bananas (capped when not plugged in) coming out of the unit. Although I have not used the razor in a while, I could in theory swap it out easy enough.

1 Like