THC no live voltage

Why am I getting lower voltage reading at the back of my VIM box?
2.56v at cnc 4&6 pin
2.56v at input barrel
1.8v on output side of VIM
1.8v to end of output cable 0.8v at spade connectors inside control box
I have checked all wiring for continuity and lose terminals. I have been through the troubleshooting for chart 4 times.

Need more information
Plasma cutter brand?
Raw voltage or 50:1 divided voltage?
Has it worked prior to this morning?

Primeweld cut 60 3rd Gen. I purchased the crossfire pro and plasma October of this year. Divided 50:1 and no it has never worked. I am just getting it set up

Have you tried hooking it up to raw voltage? Not an authority on primeweld 60. There a lot of guys that use it here on the forum that may have an answer for you. Stupid question? Is the work piece clamp on the metal your cutting?

Yes sir and I tried it on the slats. I am getting good voltage of 2.56v from the 4 & 6 pin on back of plasma cutter through the cnc plug input barrel plug. It begins to diminish inside the VIM box. It drops to 1.8v on output female plug side of VIM. It carries the same 1.8v to the THC plug on control box. Once it enters control box it drops to 0.8v.

Sounds like a bad VIM box. Reach out to Langmuir this morning? They are on west coast time, I believe?
I hook all my plasma cutters to raw voltage and have never missed a beat. I have never did the 50:1 hook-up it seems like a pain in the ass all the time. Sorry, I couldn’t be any more help. By the way welcome to the family!!

They just sent me a new VIM box that arrived yesterday. The first one that came with the machine was only allowing 0.8 through the output. This one is allowing 1.2v to 1.8v through the vim. Still holding 2.56v at the cnc port of plasma cutter as it was the first day I tested it. 2 bad VIM boxes? Dang

Sounds like a problem on the divide voltage board inside. Hard to believe two units are both bad. I know its a pain in the butt to take apart the plasma cutter but, raw voltage is the way to go

1 Like

The board inside control box or plasma?

Yes there is a divided voltage board inside the plama cutter. It has a bunch of resistors that reduce the output voltage to the correct ratio.

Just follow the directions in the Langmuir manual. Remeber that the work piece lead is the + lead. The torch is the Neg…

From my understanding of the THC troubleshooting flow chart I shouldn’t have no more than than 2.8v from 4 & 6 pin on primeweld cut 60 cnc port. I maybe wrong but I’m pretty sure. I been through that checklist 5 times and will be the 6th when I get home this evening.

That is how the VIM box is supposed to work, according to the THC troubleshooting guide. The VIM box reduces the input voltage and sends the lower voltage to the THC board in the control box. The formula for that is to multiply the output voltage from the plasma by .685 to get the output voltage.

In your case, 2.56v x .685 equals 1.75v, which seems very close to what you are getting.


Is that within range for what is necessary? I’m a xray pipe welder that is exploring new things. I can do a lot but this is foreign to me

Both your output from the plasma and the output from the VIM seems to be in the acceptable range. There is no mention of what the voltage should be on the inside of the control box. but I would assume that it should be the same as the output from the VIM.

It seems that your plasma is putting out the correct voltage and the VIM is working correctly, so any problem will be within the control box. I would check to make sure the THC module is seated correctly on the board.

1 Like

Thank you. I will do that the moment i get back to the shop this evening. I really appreciate your help and anyone else that decides to share their opinions on this particular problem

1 Like

are the THC and Crossfire options green on top right portion in firecontrol?

Yes. Its dropping voltage as soon as it enters the motion control box. Its weird and aggravating

check the cable for continuity… there shouldn’t be any crossover.

I had this very thing happen to me. I’m using the primeweld cut60. My problem was the red wire is the negative cable and black is positive. Took a couple of tries to get this straight in my head. Then un-soldered the wires and put them on correctly. worked after that.