THC No connections quick fix

Installed the THC electronics module and got a red light on it and a green light on the usb.Hooked up the VIM as instructed to my Razor weld 45. Triple checked every connections but still get a No connection on the height control . Asking for any help. Every thing else works good.

did you download the driver for it?

Down loaded fire control.

fire control is not the driver for the THC…

with your pc on and your langmuir box on…are you getting a green light on the THC top right of the screen…?
sometimes PC’s do not properly connect…go to the support page…downloads…windows 7/8 driver…load it run it

Height control = no connection
Machine = crossfire [v1.21s]
Am running windows 10

Thought windows 10 would auto download. found the drive i needed it connected.
I feel like an idiot.
Thank you for your help.

no need to feel like an idiot…these things happen.

we are all here to help…just remember to pay it forward sometime…

if it is working you can change the title to add solved to it…

1 Like