SOLVED: Z axis THC not working, torch crashing into material

I ran the THC test and voltage is within spec based on that. When I start a project with THC enabled the torch crashes into my material and never fires. I have a voicemail to support but thought I’d reach out here until I hear from them or hopefully can solve it prior. It is freshly assembled using a Hypertherm 45XP with Langmuir CPC attached. I can generate a straight cut or design without THC enabled and it works just fine.

Any ideas or items I need to check. It seems like the torch thinks the Z 0 is much lower than it is or the THC just isn’t sensing the material.

The THC doesn’t sense the material it reads voltage when torch is on. Sounds like a sticky ihs switch. The ihs switch is behind the lead screw on the z axis makes sure it isn’t touching the lead screw.

Are you getting any error messages?

Could also be programming error. Do you have the correct post processor?

I am using the post processor from Langmuir for FireControl within Fusion 360. I believe you may be right about the IHS switch posting a photo as it looks like it’s in constant contact if I’m following what your saying.

If you grab the torch head does it move up and down freely? you may need to adjust the bearings.

Doing straight line cuts did the torch touch off on the material?

Reason I asked about post processor was there is on with and without ihs. I wouldn’t see that being your problem tho.

When you move the z axis up and down watch fire control screen makes sure the small ihs light comes on and goes off.

I would say IHS not THC is your issue. If you move the torch up and down manually there is a “light” on the bottom of the firecontrol screen that should change status when that IHS switch makes or breaks. My guess is your IHS switch is not signaling the control box that the material has been contacted.

This pic was stolen from another thread: Search IHS light firecontrol

1 Like

The straight cuts I generated directly in FireControl without THC and just went up from toughing the material 1/16" by jogging Z before pressing start.

When I am above the material the IHS light is off and when I jog as little as 1/16" onto the material the IHS light blinks green

When it touches the material the switch open turns the light on. Does the torch head move freely when you raise it by hand?

Can you post g codes for failed cut?

It should be steady green I believe. Make sure the switch is not loose. can activate it manually (with a small screwdriver) to test it out or as Phillip is saying by moving the z axis by hand.

1 Like

Here are my errors. I wonder if it’s thinking my material is much thicker than it really is. I’ll have to try and generate the nc file again. I am accustomed to generating designs in mm from 3D printing and everything in CAD/CNC seems to favor inches. I will see if that helps if there aren’t any other suggestions.

sounds like You may need to lower the torch in the holder. Is his blinking or steady? Also check wire connections to ihs.

I work nights and should be asleep already. I will try your suggestions when I wake up thank you all for your assistance. I will reply then.


Make sure you raise the z up a bit before hitting start.

Also maybe video the torch so we can see what’s going on. Pretty sure this is an IHS problem.

Phillipw hit the nail on the head or the IHS on the lead screw if you will. There was a small brass tab on the back side that was touching the lead screw. I knew it was but assumed this was normal. It either came that way or happened when I moved my Z higher than I should have after getting everything together. Thank you everyone! I’m a little disappointed no return call from Langmuir support after leaving them a voicemail, but all’s well that ends well.


That is kinda odd they usually pretty good about responding from my understanding. Great to hear now you can burn some metal!!!

1 Like

I haven’t run it yet since I didn’t want to wake anyone up but after flattening out that tab the IHS light stays solid green when I run Z down to the torch touching material.

1 Like

Solved, issue was caused by a IHS brass tab making contact with Z motor lead screw

1 Like