Razorweld 45 no fire after using (solved)

i gun 2 different designs in 2 different sheets of some .040 aluminum 24x42…
I put in my third piece of metal and loaded the exact same program but now the razorweld will not fire.
I have the j45h handle so I took it off the pro and tried to cut by hand and nothing. The torch will not produce.
Changed out ALL the inside pieces with the razorweld plasma kit PLAK02, which i always use.

its just weird i have been cutting 2-3 pieces every saturday for it to just stop after completing 2 programs and inop on the third.

Any ideas?

  • I cut (not gun)

Are you getting air?

i was getting air on the last program which was only 5 min before it started doing nothing

Make sure you have air coming into your plasma. It won’t try to fire without. Could be air solenoid bad.

on the air control valve that the solenoid is attached to there is a little white lever that is popped out and turned to the valve. Should that be pushed in and turned? is the lever a reset maybe?

There is a button on the front of the RW 45 that will allow air to flow when you push it. That will tell you if you have problems with air.

Watch the gauge on the front of the RW when you have the button pushed. You should see at least 70 PSI

1 Like

Not sure… @Knick is right a good place to start .

Been busy since the issue was resolved playing catch up.
@Knick Thank you for your help on this matter. I the valve was the issue and i contacted razorweld and they sent out a new on at no charge… So long story short I’m up and running and appreciate you guys more then you know…

I’m still learning


marked this as solved for you…thanks for following up with the results