Razor cut 45 powers off (SOLVED)

Hello everyone i haven’t used forum much but i need help. my plasma comes down touches plate with a small spark and shuts down also yesterday i was getting a reading of 300v on live voltage someone have input o this would be much appreciated.

welcome to the forum…can we get some more information please…

  • do you get any errors on the screen…if so what are they?
  • have you had good cuts before and this is new…or are you totally new to the table and CNC?
  • what software are you using for post process?..Fusion360 or Sheetcam?
  • how are the consumables in the torch?

let us start with that information and see what we can do to help

so right now it wants me to check pierce hight and delay time also work clamp and intercecring lines in drawing.

please answer all the questions I have asked…if you are able to post pictures it will help.

1 Like

self trained been working with plasma for a few years now i will see what error title it is. did it again just now i went to turn on plasma and just touched it towards on position. sound it made was that of 2 wires touching creating a short sort of say. i have opened it last couple of days and didnt see anything wrong with button wiring. i use sheet cam for gcode and lightburn for drawing also jsut aqured a 6x12 torchmate and traying to learn that cad for drawings

cutting voltage lost has been happening allot and keep having to trick it into transferring arc to plate

I really have a hard time trying to understand what you problem is…
you do not seem to answer questions …
all I know so far is that you use sheetcam…

what errors are showing on your screen?

what Plasma machine are you using?

what about the consumables in the torch?..are they new or old?

have you ever made good cuts with your plasma table?

what do you mean you have to trick it into transferring arc…never heard that before.

to previous fquestions post is firecontrol one and ive had a ton of success with this table just cant figure this one out. tooling ive always had trouble with but after a cople error codes parameters get set.

tricking it i mean it fires up and acts as if its too far from plate but i know its not becauise it cuts just fine after i touch the tip with a pc of metal

the error that comes up is cut voltage lost due to the Razor cut 45 shuts down completly

English is not your main language is it?

it is very hard to understand you replies…

I am going to rest a while and hopefully someone else can read this and understand some of it.

the only thing I can think of for you right now is to increase your pierce delay.

1 Like

thank you for your time. i appreciate you trying to help. figured it out was just a faulty power switch. replaced it and back up and running. again, thank you for taking the time.

As in the relay?

no the power on button on the exterior of plasma has 4 electrical wires inside. best guess is water from table may have got in and caused a mess.

Thank you for the clarification.

Where do you keep your plasma machine?

Any pictures?

Just curious how water would have got into your machine.

probably dont need a pic but will upload later. i made a shelf undertable same size as table

Do you think you’ll continue to store your plasma torch in that location?

1 Like

Summary of what is going on:

  • I have a problem I need help with.
  • I don’t answer investigation questions.
  • No picture, no need.
  • Yeah, water was inside the plasma. Yeah, it was a faulty power switch.

I hope this topic gets deleted. It gives a bad reputation to the Razor Plasma 45. When the truth is some users are reckless.

1 Like

i do need to move it from location and razor plasma has been great to me i have no complaints switch going bad was more than likely my fault

I would disagree with you on deleting this topic.
This is a great example of properly going through diagnostics…or not going through proper diagnostics.
It shows how people here try to help…in fact try very hard to help
it also shows that what people think is one problem can actually be another…

I will mark the thread solved…