Problem with torch not refiring between cuts

I am experiencing this very problem. Torch wont fire after 1st cut until post flow is over. Only had the table running for about 30 days and this is the first i’ve experienced this problem as I have always had the post flow set to 20 seconds on my everlast 82i and it hasn’t been a problem till now. are you saying this is way to long?

If its been working all this time OK then something has changed. Bad consumables, air pressure to high, delay time changed, relay in controller, air valve in plasma cutter, etc.

Post flow should not have any thing to do with firing the torch between cuts.

1 Like

What if the electrode is sticking?


Tom is on the button I think…take the torch apart at the tip and see if the electrode moves freely un and down in the internal spring…if it stick at all…that would most likely be your issue.

Yes that can also cause a misfire.

If the electrode plunger is sticking. Remove the electrode blow everything out with air, install an old electrode and with a little pair of pliers work the electrode in and out a few times then plow it out again. then add a little silicon grease and work the plunger in and out a few more times to get the grease in it and it should free up.

Thanks for all your responses. I have taken the torch apart. It appears all internals move freely back and forth. I also contacted everlast and they had me test the air solenoid which turned out fine. Took it apart and cleaned it anyway. I still get the misfire message in firecontrol after first cut is done but prior to torch firing to make the 2nd cut. Every single time. Air pressure in the plasma cutter itself is at 65 psi I have replaced all consumables including the nozzle cup. I agree something has changed but could it be the THC is bad and that is why I’m getting the warning?

if you have not tried this…try this…
delete all fire control software with the add/delete in the control panel.
go into your files and delete the fire control folder.
re-install firecontrol.
make sure you haev ferrite chokes on the cables…
what have you got to loose right now…

I’ll try anything. The usb cable they supplied with the table has a ferrite choke on it already. Are you saying add some more?

loop it around and back through the ferrite if you can…if not add another…what ya got to loose…I have one on every line…it is like wearing 2 masks…ahahahaha

just uninstalled and reinstalled firecontrol. Still having the same issue. first cut great, rapids to 2nd postition and then another misfire waring and torch doesn’t fire. WTF!

What are you using the hand torch or a machine torch?

Machine torch ptm80 on an everlast 82i cnc total of 8 minutes of cutting time. worked great for about 5 minutes. now i get the misfire code every time after 1st cut right before it tries to make the 2nd cut on a part.

Same part/file or different files?

different files as well as trying straight line cuts I still have to wait for post flow to stop before I can get the torch to fire

Someone else had that issue but I don’t recall the solution :slightly_frowning_face:

More trial and error here. If I manually fire the torch over and over using the manual torch fire function in firecontrol while air is flowing to the torch, the torch fires every single time. But if you are relying on the program to fire the torch over and over while running on a file program for example like a bottle opener it still just fires for the 1st cut moves to the second position and then nothing, another misfire code. Any other thoughts?

Do you have THC? If so, what happens if you turn it off?

What’s your pierce delay set to?

Your controller may not be sending a strong single to the fire relay or the relay may be lose or bad causing this. Like James said your pierce delay may be in milliseconds not seconds .

Problem solved!!! I can’t believe it, but it was a pierce delay issue. Mine somehow got changed in Fusion 360 post processor to an extremely short delay. What made it worse was when I got the misfire message one of the solutions given in the message was to shorten the pierce delay which was making the issue even worse. Thanks to some help from Thomas at Langmuir, he got me straightened out and back to cutting.


he was right again…well done sir

1 Like