Not connecting to FireControl

I just upgraded to a THC on my OG Crossfire. I had FireControl installed and was able to control my table. Today my table will not connect to FireControl. Crossfire does not show in my USB devices. How do I get it to reconnect?

I also tried using my laptop and it also does not connect. Did something die in my control box. The USB light is green, I’m using the supplied USB cable but no connection.

Make sure the green LED on the LS motion control board and the red LED on THC board are illuminated when plugged into USB. This checks proper install of THC module. If no red light, check orientation and pin alignment.

May need to reinstall drivers. I had to manually install drivers for proper recognition on my computer.
https://www.langmuirsystems.com/downloads

1 Like

I have the green light. I’m not sure where the red light is, but it previously worked fine. How do you manually install the drivers. The instructions say to go to “Devices” and click on the Crossfire, but if it doesn’t show how do I update the driver.

Make sure your THC board is installed correctly first. The red LED is on the THC control board that you installed on the Motion Control Board:

If the board is installed correctly, unplug the USB from your computer and then restart the computer. Wait for complete boot up and then plug in the USB to the LS control box. You should hear the tone as Windows recognizes the device. If you don’t hear the tone, you may get a message that Windows is installing drivers/device. After that start FireControl to check connection. If you get neither tone or message and FireControl does not connect, you definitely need to reinstall drivers.

Post back and if need be I will try to post instructions on driver install…

Disclaimer : Mind you I am not a IT tech, but I can share my own experience. You may need support from LS.

1 Like

It is installed correctly. It worked fine before. I don’t think it uninstalled itself by itself. This is a driver issue or the motion control board died.

I misunderstood your initial post then. I was under the impression that you were not connecting as a result of installing the THC.

You may want to try swapping USB cable. You are getting USB power, but maybe not be communication.

If you want to install drivers manually, this is what I did:

Downloaded FireControl USB THC Driver from LS Download page:
image
Basically followed theses instruction:
image

This worked for me. I would strongly advise contacting LS if you are not comfortable taking these steps. Possibly someone else can chime in who may have experienced your same issue.

1 Like

Sorry, I can see how you may have been confused with how I wrote it. I have tried a new USB cable and I can’t do the manual driver install because “crossfire” doesn’t show up on my computer. I’m out of ideas. I sent a message to LM support for help. Hopefully they will get back to me soon. Today’s planned work is a complete loss.