No arch after FC update/new consumables (Solved)

Hi everyone, Ive read as many troubleshooting threads relating to THC and “no arch” as possible on here and I hated adding a new one, but I still can’t seem to figure this out. I was running multiple small cuts, and was managing, but kept getting a pierce delay issue. Its set at .5 on fusion so I just overriding it 20% on FC and it worked. Than suddenly it would stop cutting on certain parts to the point when I switched out consumables ( from the same box I’ve used), and did a software update. After this, Im getting no arch during a cut, and I just head a “click” during my thc test with no actual error showing. I can’t manual fire either from FC or the torch itself. Wiring is correct (front ports are not switched), relay inside the box is seated properly, its in 2t, air is ran through a water filter at around 90 psi. I unplugged my charger from my computer so there’s no weird ground/connection, tried running multiple previously successful files with no luck, torch moves to cut, touches down, raises to pierce height than stops. I’ve seen some test on here with a multimeter which I’m interested in trying, but can’t fully understand the “shorting out” part they say to do with the torch on/off etc. If anyone cares to do more thorough walk through as to what setting on my HF multimeter and where exactly to connect would be super helpful. One thing I noticed is one of the two brass spring loaded

contact pins on the torch head is flush, whereas the other pin is sticking out (which seems to be the proper position), is this correct? I can attach a photo as well.

Running: Fire Control on Mac osx v21.1.5
Crossfire Pro with THC plug and play

I am not sure but I would say that pin needs to be sticking up to make contact


If you can’t get the torch to fire using the torch trigger, then the problem is with the cutter itself not Firecontrol nor the table. Whether the pin in the torch head is the problem or not I couldn’t tell you as I’m not familiar with that style torch. But you need to get the torch to fire manually first,then start diagnosing any other remaining problems.

update: I just unplugged the two ports on the plasma and turned off the electronic box, and I CAN make a cut with the hand torch itself. Sorry I should have done all of the steps for manual cut first!

If you don’t have enough air supply from compressor to back of cutter it won’t fire.

1 Like

Im putting out around 95 psi, with a 6.5 cfm @90

Any other tips anyone can share on testing out the THC? A couple years ago there was a post on someone losing their arch during a THC test after doing a FIreControl update and was provided instructions to fix it. Anyone familiar with this?

I can’t think of any way that the THC module would prevent your torch from firing. Perhaps throw an error code, but not prevent it from firing.

If the torch fires manually from the trigger, the problem is somewhere between the relay on the control board and the plasma cutter.

Start with unplugging the torch on/off from the control box and short across the barrel connector on the end of the wire, to see if the torch fires. Shorting it just means using a piece of wire or metal to connect the inside metal surface of the connector to the outside metal surface of the connector. You are just closing a loop, which is the same thing the relay does. It takes two separate wires and connects them into a single continuous wire.

If the torch fires, then the problem is inside the control box. Either the relay is bad or the wiring between the relay and the female connector is broken or disconnected.

If it doesn’t fire, the problem is in the wire going to the plasma cutter or between the connector on the plasma cutter and the board inside the plasma cutter.


@Bfisch315 can you post the g code of the failed cut.

Okay, just to be clear. Originally you could not fire the torch by using the torch trigger, correct? But after unplugging the cables from the plasma cutter (I’m assuming the cables you are referring to are the torch on/off and the divided voltage cables) then the torch would fire when you used the hand torch trigger? Do I have this right?

Also, what plasma cutter are you using? I don’t think that has been mentioned.

Unfortunately I ended up trying other files and lost the original G code

When I initially tried cutting manually, I tried through the FC which didn’t cut, then I tried by manually by pressing the (what I thought to be) hand torch button on the front of the plasma, which is a Razor cut 45. When I press that button air continuously comes out of the torch head, which after looking at the manual, that button is the “gas check indicator”. So after setting it back to “Normal Cut Mode” and just unplugging those two front cables on the plasma, it fired how it should. So with that said, my first attempt at “manually firing” was not the correct way.

I’ll try shorting the Torch on/off and see if I can get it firing. Just to double check, this is just bypassing the original wire from plasma to Electronic box, to test the wire itself correct?

1 Like

You are not bypassing the wire. You take the end that plugs into the control box torch on/off port and short that connector while the other end is still plugged into the plasma cutter. If it fires, everything from that end of the cable to the plasma cutter is fine.

If it doesn’t fire, you can unplug the cable from the plasma cutter and short across the pins on the connector where that cable plugs into the plasma cutter. If that doesn’t fire the torch, the problem is inside the plasma cutter. Most likely one of the wires on the back of that connector is unplugged

1 Like

So while doing so, I found that this wire connected, but was a very loose connection into the box causing half of my problem. I did however notice a leak in my compressor which wasn’t allowing the psi going to the plasma to be sufficient enough, hence why it only would cut part way than stop cutting. Fixed this leak and wire connection and have been cutting solid ever since, Thank you everyone!! problem solved!!


Glad to hear it!

I marked the topic as solved.