Newbie problems

I have my Crossfire all assembled and am trying to get it cutting. I cannot get the torch to fire - it will do the dry run fine and I can hear the torch fire relay clicking if I manually try it. I have searched endless Forum posts but did not come up with any answers. I am using Sheetcam to generate the G code and FireControl for the table operation. I have the post processor set as Firecontrol and as far as I can make out all my settings are correct based on what I read in the Forum. Some things I am not sure about though are as follows:

  1. I may have wired the torch incorrectly for the torch control. I am just using a HF Plasma 45 as I was using this before I bought the table so it is nothing fancy, and it has always worked well cutting manually. I connected the torch control to the two short pins on the plug and I think somewhere on here there was a confirmation that they were the correct ones. Is there a way to check if the wiring is correct? One question I had was whether if you click on the manual torch fire tab in FireControl, should the torch actually fire or is that just to see if the relay is working?
  2. On the FireControl screen it is showing as not connected under the height control. If I do not have the automatic Z axis system then I presume that is correct?
    That is about all I can see that may be stopping the torch at present, unless I have a setting incorrect in the software which is highly likely. I am not an electronics or coding expert so a lot of this is a mystery to me and I hope I have not bitten off more than I can chew, so any suggestions or help greatly appreciated.



Welcome to the forums .

Is it this machine?

The harbor freight titanium plasma 45?

Yes, That’s the one.

If you hooked the wires from the controller to pins #1 and #2 inside the plasma cutter then it should fire the torch when you click on manual torch fire. If this does not happen then it is in the wiring or the controller.

Open the controller cover and take the relay out and install it and make sure it is fully seated, sometimes this works.

Did you bare wires and solder to inside machine torch wires or did you use the scotch lock wire connectors supplied by Langmuir. Its best to solder the wires and make sure you stripped all insulation off the supplied torch fire cable in Langmuir kit. And yes
fire control manual torch fire is to test fire torch.

check to make sure it still fires when pulling the trigger on the torch. If that works then short the end of the barrel connector on the torch on/off cable you connected tot he cutter. use a paperclip or short piece of wire and touch the inside of the barrel connector to the outside. if it fires then it’s not the cutter and more likely the control box. if it doesn’t fire then you wired it wrong to the cutter.

Thanks guys, I’ll check the wiring on the torch next weekend. I know I tested it after I wired it and all was good but I do remember that there were two sets of pins that were connected and not connected when I checked them with torch on and off, so I may have chosen the wrong set. I’ll keep you posted.

Success, I did my first cuts today. I found the problem and it was not what I expected. When I opened up the case of the plasma cutter, I noticed that the two wires connected for the torch control were very loose. The lock wire connectors need a lot of force to push them together. I think when I first connected them , they were sitting in the housing but not pushed in. So when I checked the continuity, all seemed fine, but as soon as I probably moved the case or screwed the cover back on, there was enough jiggling for them to not make connection.

I need to do some tweaking on the program settings but that will come with practice. but for the first cuts, I was pretty impressed! I am now in operation and my backlog of projects can move forward. Thanks all for your help


1 Like

Hey jeff do yourself a favor and solder those wires, the best way for electrical connections.
best thing to do with those scotch lock wire connector’s is throw them in the garbage…

Thanks, I did not know that ! First time I have ever used them. Solder it is!

More issues, went to load a new job into fire control and got this message. I am sure i did nothing different to previous .
“VALIDATION ERROR No program speed found. This Program will not be loaded…”
I searched here and found a couple of references but no real answers as they were combined with other larger problems!

Any help appreciated as always.

Forget this, I solved my own problem for once - the post processor or was not set to Fire Control - seems like that does not get remembered from project to project. All good and back in business.


1 Like