New machine firecontrol locked out (Solved)

i tried the oldest version on the dl page 20.062 and it installed but wouldnt open at all, then i tried the next newest one 21.14 and it installs and opens but does the same thing. the "connection troubleshooter says try flashing firmware which i did, no change. it send me now to the same place ive been to troubleshoot which is a dead end. I have tried everything they suggest and now it is in their hands evidently. i know i cant be the only person to have this happen id think there would be more detailed trouble shooting or testing. i know its a gen 2 box It has z axis, i have tried 2 laptops, 2 usb cables , reinstalled firsehare and drivers manually. I have green and red lights in the box on the table as it states I should. THC appears to be connecting properly, device manager sees both but shows no firmware version for Firecontrol. thanks so much for trying. ill report back when i hear from them

Oh yeah Casey couldn’t get 20.6 to install on windows 11 either.

dumb question but to be sure, the controller needs to be all hooked up and turned on before you launch Firecontrol.

nope, just connected to the computer. if you have another computer say inside the house, you can take the control box off the leg and take it inside to connect to another computer. the mainboard is powered by the usb port.

the main power switch powers the motors.

Im just saying, be sure the controller is connected to the computer and powered on before you launch Firecontrol.

@JGeorgiadis
Did you get your issue resolved?

Same issue here - but the problem occurred after I had run a successful cut program. Been through everything they suggest, even tried deleting FireControl and reinstalling. Still getting the error message, and cannot even jog the table until this gets cleared. FireControl showed version 21.1.5. Now I’m getting an error message when exiting - shows to be from FireControl.exe "Child process exited with code 3221225477.

Don’t know if it matters, but after running the successful cut, I attempted to cut the same file again, and the x-axis gantry started jamming / twisting. Attempted to “Home” the machine, and the movements were very jerky and then stopped completely. Right after that is when I got the “connection error” message noted in this thread. Planning to message support in hopes I get a simple fix on Monday. Thanks for any help.

they are sending a new pc board for the electronics box. ill report back when i get it installed

1 Like

new board got here on Monday. Installed it and that was the issue. Thanks to Langmuir. I was able to jog the machine , tighten the final parts on x and y lead screw and run the break in program.

4 Likes