New Guy Need Help

JUST SETTING UP MY XR. Can’t get the torch to fire. Razorweld 45

Are you trying to get it to fire by running a program or by using the manual fire button in firecontrol?

.5sec minimum Pierce delay pierce delay?

I think some of the razor weld might have had swapped ports in the front of it as well, so that also may be an issue?

Is your razor weld coding anything out? Troubleshooting light?

Is there an audible click coming from the electronics enclosure when you’re asking it to fire?

@oldiron Welcome to The Forum

I have tryed both ways. Strait cut and manual. Nothing.

No Troubleshooting light. No click.

Switch the plugs on the front of the plasma. Switch the torch fire and divided voltage.

I tried that it maxed the voltage onthe THC

I just tried jumping the pins on the plasma itself.Still no fire. Bad plasma cutter?

Did you try to jump the pins on both the divided voltage port and the torch on Port?

Incase they are switched.

I would make sure you have your consumables installed properly and the right air pressure is going to your machine also.

Yes I tried both sets of pins.

Air coming in is set at 120 air coming out is set at 75.

Will double check consumablles and give it one more try.

Thanks for the help.

Removed and reinstalled comsumables, still won’t fire.