Motors Stop Working in middle of Run

I’ll be jogging, or running a test profile, or even just SITTING there, and I’ll hear the motors go from nearly quiet to start to buzz with a high frequency, completely randomly. Then, Mach 3 thinks I’m moving the torch, but NEITHER X or Y motors are actually moving. This is not the result of jamming. There’s something that simply stops driving both motors simultaneously. If I’m in the middle of a run, the run continues in Mach 3 until the end, but my torch stays still and fires at the ‘appropriate’ times from the profile. I think it’s a problem with something in the electronics enclosure.

Troubleshooting I’ve tried:

  • This happens with or without the torch on. (I have no loops in my USB cable or any other for that matter.)
  • I’ve tried 2 different ferrite protected (even gold plated) USB cables. No help.
  • Rebooting or shutting down computer does not help.
  • Plugging in USB cable again or into a different port on my laptop doesn’t help.
  • Only turning the unit completely off USUALLY resets it, but NOT ALWAYS.
  • Happens while running a profile, jogging, OR even just sitting there doing nothing. The motors will just start to do a low volume squeal (both X & Y simultaneously).

This just started in the last couple days when I had placed a max ipm of 150 (since I have problems running above 200 ipm from rail vibration and binding- I believe a completely separate issue that I hope will be fixed when I receive and install the XL package tomorrow!!!). I used the motor tuning feature to change the upper speed limits for X & Y until this other issue gets resolved.