Major issues with Y axis - SOLVED for now

Anyone on here have issues with their Y axis on the XR? Iv been talking with Cam at tech support going back and forth and Iv spent so many hours on this. I can home machine and get it running at 200 ipm but once I go to 400 ipm it shifts off. Iv double checked so many things. They say 90% of this issue would be lead screw alignment, Iv done it 3 times and honestly even with the guide tool they give you, there is so much play in the system.
I noticed every time I homed the machine, I’d measure the distance from the aluminum uprights on the Y axis back to the aluminum bracket that holds the rails. It was consistently 1/8 off after homing on Y1 vs Y2 . So I compensated the limit switch stop to where now the machine is equal distance on each side after homing. (its seems to not make any difference)
I got the idea that when setting the limit switches as you bring machine all way back like it says, the washer that bolts the felt washer in place could differ from one side to another. So if one washer isn’t threaded in as far, then that is going to hard hit the machine bf the other side and ideally give a a different limit switch setting and crooked homing. May not be making sense without pictures but thought just by how it was acting that the Y1 and Y2 weren’t trailing the same so I consistently was noticing that difference after homing.

My guide wheels were good on set up but I noticed twice now when machine was homed I looked up and noticed the top front guide wheels were not touching the rails. Maybe they came loose when machine went outta square, but I reset them.

Iv measured and compared alot of things, Im just not able to get it working. Any help would be appreciated. Im absolutely dreading tearing the motors out and making sure everything is working with factory presets. They sent me a troubleshooting guide on how to do it. There are just so many things it can be, I totally wasn’t expecting the design to have all these variables. It looks and I believe is still better than the PRO, but so far Iv had no success jogging this thing past 200ipm. when I initially set it up (and did the lead screw alignment wrong, totally missed it in instructions), I actually had the most success with the machine. I opened up a file and let it dry run and it was ok, so only about 2/3 of table at that time could handle 400ipm jog, it would consistently hang up about 1/3 way past home. Now I can’t even do that. I still have to talk with Cam on identifying if its a slipping issue or a binding. I can’t tell what its doing.

Are the guide rails absolutely parallel? We basically used a gauge block (it was a couple of 1/2 sockets that were almost perfectly sized). We used these to ensure that each rail was parallel to the table. Also worked really hard to make sure that the table was square (each Y axis assembly lands at the exact spot on both sides). If the table isn’t square then the spacing you calculated for the rails will be off.

1 Like

I had the same exact issue . It was the lead screws . Tech gave me a sheet to re align I’ll see if I can find it.

Pretty sure, I checked alot of things multiple times. You would think at 200 ipm it would come off track if alignment was that off. I may tear it all back down and restart, I have no choice as Iv spent hours on it, lots of rabbit holes to go down.

yah they sent me a pdf file on it and tried sending me a video but I couldnt get it to work. Originally when I set up the lead screws I missed in the instructions where it says work on one end and one side, then tighten it up, push X gantry to other side and tighten it up, then do same on the other rail. So when I initially set it up I had gantry all way at home, I reset it exactly how they said and it didn’t help.

Even with the J hooks on the rail there is sooo much play in the end bolts that are the aluminum fixture. There are tapped holes in that fixture where the big washer is, I asked them about that but didn’t get an answer, not sure if that is for lining up or not. This pic is the first time I set it up when the X gantry was all way at home. But what Im saying is even if the lead screw is touching the J hook this washer has alot of play, in out, up and down. Iv since tried keeping the washer as even as I can.

I suspect that your ballscrew alignments are fine.

Loosen the screws that secure the felt wipers and remove the felt wipers entirely. Try to jog the machine, does it jog at 400? If it does, then the felt wipers were being compressed too much and causing excess friction.

If it still wont jog properly, try this: Power the machine off and manually rotate one of the Y1 ball nuts by hand. Continue rotating it until it becomes hard to rotate. Start rotating it the other way. It should become easier to rotate before getting harder again. Back the ballnut off until its easiest to rotate right in the middle of those two extents. Power the machine back on and try to jog it at 400. Let me know your result.

1 Like

There should not be any play in those end bolts.

Mine has been working fine, and went out today to cut some signs, and I am having the exact same problem. Will progress just fine at 200IPM or less on Y axis both directions, but as soon as I jog it at 400IPM it goes crooked, and binds up… I guess I am going to try and realign my ball screws and try the above test with manually aligning the y axis.

If your machine was previously jogging fine I wouldn’t bother with realigning your ballscrews.

But I would recommed trying what I explained in my previous post.

Just tried all of the above, nothing worked. It almost seems like it is a software problem, how can it be totally fine at all movement speeds except the 400IPM. Like at that speed one of the motors for some reason isnt working as it should anymore. Just spent an entire day, and nothing fixed it.

tried both of these, and then re ran the ball screw tightening procedure for both sides again, and still does it.

I did notice that when the machine is at home, the top two bearings are sitting on the y axis tube on both sides of the gantry. But when I move the gantry manually to the front of the machine the right hand side top bearing toward the front of the machine is no longer touching the y axis tube anymore. Have never seen this before, could the actual y axis tube be bent? I dont know how, since it was working just fine a few days ago.

Can you check to make sure that the pulleys are tight on both sides? If one side is intermittently slipping it could cause the problem you are seeing since it will cause the gantry to rack.

the pulley with eccentric bolt on the bottom or the two pulleys on top? They have a 13mm lock nut, and they are not all the way, tight none of them, but i didnt want to keep tightening them, because i figured they were set. how much torque should be on that nut?

top pulleys or bottom pulley with eccentric bolt?

I am referring to the timing belt pulleys. They are secured by large nuts onto steel hubs. It’s possible that one or more of those pulleys are slipping on the hubs and causing one side to get ahead of the other when jogging. I’d check to see if you can get the pulleys to slip on the hubs with hand pressure and if you can, further tighten those nuts.

Alternatively if you can put some match marks on the pulleys to the nuts that would tell if you the pulleys are slipping when it binds up.

1 Like

i will go try that.

all 4 of those are tight, checked on both sides of the table and both sides of the belt. top and bottom. I did just use the wireless remote and if I push on the side of the gantry with my hand while moving the gantry in the y direction with the wireless keyboard, it will jog, as soon as i let off pressure, it binds… so it is definetly either the right side is not moving at 400 IPM, the left side is moving faster then 400IPM, or something is binding on the right side of the table

How much slack is there in the timing belt? If the belts are excessively tight it can cause binding.

probably a little more then a 1/4 inch of deflection, not tight by any means